1

My panel clock is showing time in UTC. This is recent behavior, and I believe it is a recent regression, but I'm not 100% sure so I'm posing this as a question first.

Here's a screenshot of the clock in the panel, along with the clock settings.

Panel clock in UTC, timezone is correct (PDT)

Here's the output of 'sudo dpkg-reconfigure tzdata' after taking the settings I had already selected:

Current default time zone: 'America/Los_Angeles'
Local time is now:      Thu Aug 27 11:51:33 PDT 2015.
Universal Time is now:  Thu Aug 27 18:51:33 UTC 2015.

It looks to my like my timezone is set correctly, but my panel clock is not.

Also, to reiterate, this is a new issue; my panel clock had been showing the correct time until this week.

Anyone know how to fix this issue? Is it a known bug?

Edit: I think this screenshot better shows the issue. The clock knows both the correct PST time and the correct UTC time and it knows which one I am. It's just displaying the wrong one.

hover time shown

  • 3
    Is this a dual boot Windows-Kubuntu machine? If so, the problem is known. See askubuntu.com/questions/169376/clock-time-is-off-on-dual-boot – user68186 Aug 27 '15 at 18:58
  • This is a virtualbox system, but I don't think that has anything to do with it. 1. I just tried the UTC=no fix, no change. 2. Virtualbox has correctly set "Hardware clock is UTC" 3. Note that the panel clock knows it is displaying UTC. The timezone is shown in the screenshot. The problem isn't what time the system thinks it is; the problem is what timezone is being displayed. – Cory Aug 27 '15 at 23:06
  • Check this link: askubuntu.com/questions/3375/… – Karlos Sep 11 '15 at 5:26
  • Are you sure that clock at the machine in question runs correctly? Ī̲ don’t ask about time zones, Ī̲ ask about (absolute) time. – Incnis Mrsi Sep 11 '15 at 18:57
  • @IncnisMrsi I don't understand the question--those were the correct times when I took those screenshots. It's displaying the UTC time in the taskbar instead of PST. – Cory Sep 11 '15 at 19:06
2
+50

Right click on the widget and select 'Digital Clock Settings' -> 'Time Zones' and make a selection in 'Clock defaults to'.

  • This appears to be the correct way to change the setting I changed manually in the config file. Thanks! – Cory Sep 14 '15 at 17:38
1

In the end I got desperate and just grepped for UTC in my home directory. So I discovered ~/.kde/share/config/plasma-desktop-appletsrc

This config file, for me, contained these two lines:

timezone=UTC timeZones=UTC

Removing these lines and logging out and back in fixed the problem.

0

This hit me over the weekend - Friday afternoon, it showed the correct time; Monday morning, it showed UTC.

I fixed it by right clicking the time, selecting "Digital Clock Settings", then checking "Show time zone" and clicking "Apply".

The "Show time zone" check box was unchecked when I looked at the settings - I don't know if it was checked before or not.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.