2

I have just upgraded to plasma 5.3 and the following 2 packages are broken - is there an easy fix to sort out this dependency problem ?

sudo apt-get -f install
[sudo] password for paul: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gstreamer1.0-libav gstreamer1.0-nice kde-telepathy-call-ui kde-telepathy-declarative kde-telepathy-desktop-applets
  kde-telepathy-filetransfer-handler kde-telepathy-minimal kde-telepathy-send-file libfarstream-0.2-2
  libkf5dbusaddons-bin libkf5iconthemes-bin libkf5parts-plugins libkf5xmlgui-bin libkpeople4
  libktpcommoninternalsprivate8 libktploggerprivate8 libktpmodelsprivate8 libktpwidgetsprivate8 libqtgstreamerui-1.0-0
  libtelepathy-farstream3 libtelepathy-logger-qt4-1 libtelepathy-qt4-farstream2 qml-module-org-kde-people
  qml-module-org-kde-runnermodel qml-module-org-kde-telepathy qtgstreamer-declarative sonnet-plugins
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  kde-l10n-de kde-l10n-engb
The following packages will be upgraded:
  kde-l10n-de kde-l10n-engb
2 upgraded, 0 newly installed, 0 to remove and 249 not upgraded.
1 not fully installed or removed.
Need to get 0 B/40.9 MB of archives.
After this operation, 518 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 466356 files and directories currently installed.)
Preparing to unpack .../kde-l10n-engb_4%3a15.04.0-0ubuntu1~ubuntu15.04~ppa4_all.deb ...
Unpacking kde-l10n-engb (4:15.04.0-0ubuntu1~ubuntu15.04~ppa4) over (4:14.12.3-0ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/kde-l10n-engb_4%3a15.04.0-0ubuntu1~ubuntu15.04~ppa4_all.deb (--unpack):
 trying to overwrite '/usr/share/locale/en_GB/LC_MESSAGES/libkgeomap.mo', which is also in package libkgeomap-data 1.0~digikam4.7.0-0ubuntu4
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../kde-l10n-de_4%3a15.04.0-0ubuntu1~ubuntu15.04~ppa4_all.deb ...
Unpacking kde-l10n-de (4:15.04.0-0ubuntu1~ubuntu15.04~ppa4) over (4:14.12.3-0ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/kde-l10n-de_4%3a15.04.0-0ubuntu1~ubuntu15.04~ppa4_all.deb (--unpack):
 trying to overwrite '/usr/share/locale/de/LC_MESSAGES/libkgeomap.mo', which is also in package libkgeomap-data 1.0~digikam4.7.0-0ubuntu4
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kde-l10n-engb_4%3a15.04.0-0ubuntu1~ubuntu15.04~ppa4_all.deb
 /var/cache/apt/archives/kde-l10n-de_4%3a15.04.0-0ubuntu1~ubuntu15.04~ppa4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Many thanks

-- Update --

I removed libkgeomap-data and then did a full update - seems to be working now !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.