How do I automatically unlock the keyring at login on my Lubuntu 14.04 system?

There are a lot of answers to this problem on this site and Ubuntu Forums, but none are applicable to a 14.04 Lubuntu system - it appears that the Passwords and Keys dialog has changed significantly since those answers were supplied.

SO -

  • answers telling me to tick the box for "Unlock the keyring at login" in the Seahorse app do not work, because it is not there.

  • answers (like this one) telling me to tick the box on the "Unlock Keyring" dialog box to unlock it at login do not work, because it is not there

  • auto-login was never set on this system, so that is not a contributor, and this answer does not apply

  • the issue does not arise with Network Manager (like this one), but rather with Deja-dup

  • I do not want an answer that involves removing the keyring password entirely - like this one

How can this rather basic requirement be met on a Lubuntu 14.04 system?

[edit] - here is the dialog box requesting the keyring unlock. enter image description here

  • I have Lubuntu 14.04 fully updated but don't have any "unlock the keyring at login" requirement. Could you put up an image of what this keyring looks like? I'm assuming you aren't referring to the vanilla login screen. I too haven't set autologin.
    – DK Bose
    Aug 27, 2015 at 15:33
  • Also, is this a pure Lubuntu install?
    – DK Bose
    Aug 27, 2015 at 15:34
  • Yes, it's a pure Lubuntu install from scratch. The "unlock the keyring" screen does not appear at login, but rather when I start an encrypted Deja-dup backup. Aug 27, 2015 at 16:14
  • Deja-dup isn't part of default Lubuntu. And if the unlock screen doesn't appear at login, you could edit your question. As it stands, it appears that the keyring unlock appears at login (as per the first sentence).
    – DK Bose
    Aug 27, 2015 at 17:37
  • I am not sure what you are referring to - my goal is to unlock the keyring at login automatically. Aug 27, 2015 at 17:40

2 Answers 2


Make sure, libpam-gnome-keyring is installed on your system

sudo apt-get install libpam-gnome-keyring

Also you should have a login keyring in ~/.gnome2/keyrings/login.keyring

---Edited by OP to cover another situation.

I installed LXDE on my Ubuntu 14.04 system and started getting this keyring popup again when I took a backup. libpam-gnome-keyring was already installed on this system! To fix it, I had to add a line of text to two files, like this:

To /etc/pam.d/passwd add:

password optional pam_gnome_keyring.so

And to /etc/pam.d/login add:

session    optional     pam_gnome_keyring.so        auto_start

This will unlock the keyring on login when I log in through LXDE.

  • Verified to work on my 64-bit Lubuntu 14.04 install. Thanks! Aug 28, 2015 at 3:06
  • 1
    I've been trying to fix this issue from 14.04 and thanks to this answer I've finally fixed it on 16.04. It was driving me crazy!
    – jonthalpy
    May 28, 2016 at 23:04
  • On my lubuntu 16.04 ~/.gnome2/keyrings/login.keyring does not exists. I created it, empty, but above solution does not work. Every time Skype Alpha requires to enter username and password and after that Keyring "Default" dialogue appears. Sep 12, 2016 at 7:27
  • 3
    After this: "Renaming the folder /home/username/.local/share/keyrings to /home/username/.local/share/keyrings.old and a restart solved my problem. " source: Mint Community, Skype Alpha on Lubuntu 16.04 did not ask for Keyring. Sep 12, 2016 at 7:43
  • it's simpler to just install seahorse
    – caub
    Nov 2, 2017 at 7:15

This may not be relevant to this specific question, but I came across it while experiencing a very similar issue on Ubuntu 19.10 and wanted to share what worked for me in case someone else comes across this while googling like I did:

I tried disabling SSH Key Agent (GNOME Keyring: SSH Agent) under Startup Applications, then rebooted. This appeared to have no effect as I still got two prompts immediately on login, which I dismissed. I then noticed that the calendar applet had crashed and was asking if I wanted to submit a report. I put two and two together and went to Settings > Online Accounts, removed my Google account, and rebooted again.

This appears to have resolved the issue for now. I'll do some further testing by re-enabling the SSH Agent and seeing if I can log back in to my Google account without it causing further problems. I'm assuming it was something to do with my credentials expiring, but need to do some reading to understand it further. I plan on returning to this post and making edits to reflect whatever I'm able to uncover/learn. Hopefully it'll be of use to someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .