I failed to install VMware Player in my Ubuntu 14.04 installed on an external hard drive.

The steps I'm taking are below (tried these steps 4 times, restarted my OS but nothing works)

  1. Installed dependencies.

    sudo apt-get install build-essential linux-headers-$(uname -r)
  2. Downloaded and tried installing VMware Player 6.0.2 and 6.0.6 (32-bit) as I am running Ubuntu 14.04 32-bit.

  3. Nagivate to downloaded directorry in terminal and run these commands

    sudo chmod +x VMware-player.....bundle  
    sudo ./VMware-player......bundle  

    and it started installing and gave me a success message.

  4. After installation when I ran it, it tries to install something and generates an error message asking to look in the log.

The last entry in the log is: Failed to build vmnet. Failed to execute the build command.


VMWare player 6 had some issues with the newer kernel versions, and requires patching in order to compile the vmnet modules. Patches can be found on GitHub.

An easier solution may be to use VMWare player 7

  • Not able to find VMWare Player 7 or above for 32-bit. At this link my.vmware.com/web/vmware/free#desktop_end_user_computing/… all player 7 and above are for 64-bit. Do you have some link from where i can download VMWare 7 for 32 bit – Shahbaz Rauf Aug 27 '15 at 18:18
  • No - I see that you are correct, and that the 32 bit supports stops with version 6. The scripts available at the GitHub sitework quite well, however, and will allow you to compile the appropriate modules. – Charles Green Aug 28 '15 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.