I have 2 monitors in my desktop. The one has a smaller resolution than the other (don't know if it matters for this issue). From Display I have disabled mirroring, so the first monitor continues to the other.

Today I installed Braid. When I launch it, it goes fullscreen. When I quit the game, the setting have reverted to the mirroring of monitors (and with the smaller resolution), and I have to set them up each time.

Is there a solution for that?

The GPU is sapphire radeon hd 3870, haven't install any extra drivers for the GPU, 64bit CPU, using gnome-shell

The output of xrandr

$ xrandr
Screen 0: minimum 320 x 200, current 2464 x 900, maximum 8192 x 8192
DVI-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 228mm
   1024x768       60.0*+   75.1     75.0     70.1  
   832x624        74.6  
   800x600        75.0     60.3     56.2  
   640x480        75.0     66.7     60.0     59.9  
   720x400        70.1  
DIN disconnected (normal left inverted right x axis y axis)
DVI-1 connected 1440x900+1024+0 (normal left inverted right x axis y axis) 410mm x 257mm
   1440x900       59.9*+   75.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1 
  • The GPU is ATI. 64bit CPU. Anything else? – George Kastrinis Oct 15 '11 at 5:04
  • Add it to your question, comments get buried here. If you know the exact model that might help too. – Jorge Castro Oct 15 '11 at 5:04
  • 2
    Do you see the same behaviour if you run in windowed mode? /opt/braid/braid -windowed -width 1024 – kikixx Oct 18 '11 at 18:34
  • @kikixx Sorry for the delay. No when I run it in windowed mode, it's ok. So the problem rises with the fullscreen I guess. Any ideas? – George Kastrinis Oct 21 '11 at 15:34
  • I tried it with my monitor, and it turned off the secondary monitor on starting braid. Quitting braid did not turn on it either, and I had to do it in Displays manually. – Nemo Oct 23 '11 at 12:03

I don't have braid myself but have found this issue else where. What I can only suggest is two workarounds:

1) run in windowed mode, as detailed in comments above, which sounds like it works.

2) create a new launch script as detailed on the WINEHQ page linked above, to use xrandr after braid quits to return the correct resolution.
/opt/braid/braid && xrandr --output DVI-0 --mode 1024x768 && xrandr --output DVI-1 --mode 1440x900

edit: changed suggested xrandr command to match OP output

  • I put the output of xrandr in the first post. Could you help me for the command mentioned above? Thx :) – George Kastrinis Oct 23 '11 at 11:40
  • I managed to make it work with /opt/braid/braid && xrandr --output DVI-0 --mode 1024x768 && xrandr --output DVI-1 --mode 1440x900 --right-of DVI-0 Thx :) – George Kastrinis Oct 24 '11 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.