0

I installed Ubuntu 14.04 to make a dual boot system after a fresh installation of Windows 7 (64-bit, Professional). Windows 7 was installed in UEFI mode on an SSD, after that I shrunk the main partition and booted the Ubuntu boot stick in UEFI as well. Windows at that point worked without any problems.

I was following a guide, but was not aware of the specifics of UEFI, and here is where I believe I went wrong the first time.

While installing Ubuntu I I created a swap space bigger than my RAM on the SSD and a partition for root formatted in ext4. I also created a home partition on an HDD. What the guide I was using at the time did not mention was telling the installer to change the “Device for boot loader installation” to the EFI partition already there. Instead, it remained on /dev/sda.

Installing Ubuntu went off without a hitch, and when I tried to boot there was the list containing Ubuntu and Windows. I then chose Windows, but it would only show a loading bar with "Windows is loading files" and then return to GRUB.

Following additional posts I found, I used boot-repair, which resulted in GRUB showing Windows 3 times, but still not Windows loading. I tried a few things more, but it was hard to find information as most of it seemed to pertain to Legacy mode or Windows 8.

I deleted the partitions, re-formatted the drive again and repeated the process a few times, doing a few things differently, but always returned to the same problem with Windows not booting.

The last time, I installed Ubuntu to the HDD instead, with Windows on the SSD, and Ubuntu again works fine, but Windows won't boot. I ran the Windows repair utilities, ran chkdsk /f, but the only thing that produced any change was the physical memory repair. When I did that, when booting Windows, the Windows 7 welcome screen flashed for a second, but returned to GRUB after that.

Running chkdsk for the first time also showed a few errors on the SSD, but after that it did not show any more. I also ran TestDisk, which showed everything as ok.

At this point I've been at it for two days, and I don't know what to do.

marked as duplicate by David Foerster, Community Jun 3 '18 at 7:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Boot-Repair cannot fix most Windows issues. But post link to summary report just to see configuration: help.ubuntu.com/community/Boot-Info If Windows 7, it has no secure boot mode, you did not turn that on in UEFI or leave it hibernated? And if UEFI you should be able to always directly boot Windows from UEFI and have it work. Otherwise just Windows issues. Grub only boots a working Windows installed in same boot mode either both UEFI or both BIOS. – oldfred Aug 26 '15 at 17:16
  • I actually wrote all of them down, I believe the current one is this: paste.ubuntu.com/12199310 Also, I looked for secure boot in my BIOS but could not find it there. I cannot boot into Windows at all, but only after Ubuntu installation. Both are UEFI. – Arne Aug 26 '15 at 17:49
  • You have both boot loaders in MBR & ESP. So you need to always boot in UEFI mode. Nothing obvious stands out, Windows looks normal, so something internal. If Windows does not directly boot from UEFI in UEFI mode, you need to make Windows repairs. You do have Ubuntu installed on a MBR(msdos) drive. With Ubuntu you are able to boot that install in UEFI mode only because sda is gpt partitioned. Once you start using UEFI, better that all drives be gpt partitioned. – oldfred Aug 26 '15 at 18:29
  • The usual Windows repair utilities didn't do anything. Tried the automatic thing, bootsect, chkdsk, ... But why does Windows break the moment Ubuntu is installed? Oh, and how exactly do I go about partitioning them the right way? I did it through shrinking in Windows, then doing the rest in Ubuntu installer. – Arne Aug 26 '15 at 19:02
  • That should be correct. And usually we have seen Windows 7 dual boots better than Windows 8 with UEFI as no secure boot nor fast startup (hibernation) issues. Did you run chkdsk 3 times. Some require several passes to fix everything. And after any resize chkdsk is required. Are you running fixes from a UEFI repair boot? – oldfred Aug 26 '15 at 20:33
0

Okay, finally got it to work this morning.

This time I installed both to the SSD again, making extra sure to direct Ubuntu to the Windows EFI partition during installation.

The only two things I really did differently this time was formatting the HDD in GPT and running chkdsk three times on both the SSD and HDD, so thank you very much to oldfred for those suggestions.

Worked perfectly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.