2

I have a problem. I have installed Windows 10 on /dev/sda1 and Ubuntu 14.04 on /dev/sda6. I use GRUB as bootloader but (I don't remember since when) when I choose Windows in the menu it does not boot and returns to GRUB.

I tried to reinstall GRUB but nothing worked so far. If I run sudo update-grub the system considers a Windows 7 bootloader and writes the menuentry. But why does it not boot?

UPDATE#1:

I followed your instructions cl-netbox and reinstalled GRUB as follows:

sudo mount /dev/sda7 /mnt
sudo mount -o bind /dev /mnt/dev
sudo mount -o bind /sys /mnt/sys
sudo mount -t proc /proc /mnt/proc
sudo cp /proc/mounts /mnt/etc/mtab
sudo chroot /mnt /bin/bash
grub-install /dev/sda
update grub

Now it does not return into GRUB after selecting Windows in bootmenu but Windows still does not boot. There is only a black screen showing _

Could that have something to do with the following message after executing?

bootrec.exe/scanos

Searching for Windows-installations was successful. Number of identified installations: 1 [1] C:\Windows.old\Windows (sorry for bad translation)

I have updated from Windows 7 to Windows 10

closed as off-topic by David Foerster, user117103, Zanna, Eric Carvalho, TheWanderer Feb 1 '17 at 1:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – David Foerster, guntbert, Eric Carvalho, TheWanderer
If this question can be reworded to fit the rules in the help center, please edit the question.

  • "bootrec.exe/scanos" is a Windows command and we are an Ubuntu support site. If you want help with that I would suggest asking this on superuser.com "Could that have something to do with the following message after executing" We can not answer this. And the last bit has me believe your Windows is messed up and it probably is not grub that is the problem but the OS itself. – Rinzwind Aug 27 '15 at 13:35
  • Yes, well at this point of perception I've already been – Phile Reinhardt Aug 27 '15 at 13:45
1

Maybe the Windows BCD store is corrupted.

To fix this boot from Windows install media.

On the "Install now" screen choose -> Repair your computer
In the System Recovery Options select -> Command Prompt

Execute the following commands:

bootrec.exe /fixmbr  
bootrec.exe /fixboot  
bootrec.exe /scanos  
bootrec.exe /rebuildbcd  

Shutdown the computer and boot from Ubuntu install media.
Reinstall GRUB and run the update-grub command afterwards.
Now you should be able to boot into Windows from GRUB menu.

  • I'll try it later on when I have time for it. But should I make a backup? Or is there no danger to lose files? – Phile Reinhardt Aug 27 '15 at 11:43
  • As you only work on the boot environment, you most probably won't loose files. Anyway it is always a good idea to perform a backup before starting to work on system partitions. I recommend to use Clonezilla for that task. I am using it constantly for years now and it never let me down. – cl-netbox Aug 27 '15 at 11:59
  • We are not a Windows support site. – Rinzwind Aug 27 '15 at 13:30
  • 1
    Yes sorry about that but I couldn't know that it would be a problem of Windows as I asked the question so.. – Phile Reinhardt Aug 27 '15 at 13:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.