0

MaaS = ubuntu 15 Nodes = ubuntu 14

Using maas: 1.7.6+bzr3376-0ubuntu2~15.04.1 http://pastebin.com/4nCxtMg2

The node fails after a PXE boot curtain install request. Cloud init info from node: http://pastebin.com/TPJaNmHT

syslog: http://pastebin.com/JjMu4kVV

Specifics that I do have concern over

cloud init: Aug 26 10:11:52 ubuntu pollinate[881]: ERROR: Network communication failed [60]\n10:11:52.438763 * Hostname was NOT found in DNS cache

syslog:

Aug 26 10:11:52 high-pin kernel: [   22.400525] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
    Aug 26 10:11:52 high-pin kernel: [   22.400806] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
    Aug 26 10:11:52 high-pin kernel: [   23.155507] init: udev-fallback-graphics main process (784) terminated with status 1
    Aug 26 10:11:52 high-pin kernel: [   23.822992] init: cloud-init main process (745) terminated with status 1
    Aug 26 10:11:52 high-pin kernel: [   23.853475] init: failsafe main process (918) killed by TERM signal
    Aug 26 10:11:52 high-pin rsyslogd-2039: Could no open output pipe '/dev/xconsole': No such file or directory [try http://www.rsyslog.com/e/2039 ]
    Aug 26 10:11:52 high-pin kernel: [   23.931456] type=1400 audit(1440583912.734:8): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/sbin/dhclient" pid=1110 comm="apparmor_parser"

Other Systlog message:

Aug 26 10:12:03 high-pin kernel: [   34.574589] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
Aug 26 10:17:03 high-pin kernel: [  333.909164]  connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 4294973356, last ping 4294974608, now 4294975860
Aug 26 10:17:03 high-pin kernel: [  333.909283]  connection1:0: detected conn error (1011)
Aug 26 10:17:03 high-pin iscsid: Kernel reported iSCSI connection 1:0 error (1011 - ISCSI_ERR_CONN_FAILED: iSCSI connection failed) state (3)
Aug 26 10:17:12 high-pin CRON[1654]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Aug 26 10:17:12 high-pin iscsid: connection1:0 is operational after recovery (1 attempts)
Aug 26 10:28:20 high-pin kernel: [ 1010.724344]  connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 4295142724, last ping 4295143976, now 4295145228
Aug 26 10:28:20 high-pin kernel: [ 1010.724413]  connection1:0: detected conn error (1011)
Aug 26 10:28:20 high-pin iscsid: Kernel reported iSCSI connection 1:0 error (1011 - ISCSI_ERR_CONN_FAILED: iSCSI connection failed) state (3)
Aug 26 10:28:40 high-pin iscsid: connection1:0 is operational after recovery (2 attempts)
Aug 26 10:33:26 high-pin kernel: [ 1315.964125]  connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 4295219108, last ping 4295220360, now 4295221612
Aug 26 10:33:26 high-pin kernel: [ 1315.964194]  connection1:0: detected conn error (1011)
Aug 26 10:33:26 high-pin iscsid: Kernel reported iSCSI connection 1:0 error (1011 - ISCSI_ERR_CONN_FAILED: iSCSI connection failed) state (3)
Aug 26 10:33:29 high-pin iscsid: connection1:0 is operational after recovery (1 attempts)

looking up the hostname via "nslookup high-pin" does not work, however "nslookup high-pin.maas" does. the resolv.conf does not contain a search domain. Is this normal for a curtain install?

nslookup, apt-get upgrade, apt-get update, ping, all work and routing.

Maas event log:

http://pastebin.com/w9dQs6Ws

This node was working 1 day ago, the only thing I can think of is possibly the maas log might help? It did update to a new version of the image via a sync.

MaaS log:

http://pastebin.com/w8wt4d1j

Any ideas on how to chase down what I might need to tweak to fix this?

0

It turns out that it was just a mirror issue. changing from archive.ubuntu.com to one of the mirrors listed here:

https://launchpad.net/ubuntu/+archivemirrors ended up working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.