0

I am unable to install ubuntu on my windows-10 HP-laptop, through usb disk.The computer is unable to detect the USB while in UEFI mode(secure boot,fast boot turned off),but is detecting when in legacy mode.And I am able to install ubuntu in legacy mode,but ubuntu wont show up during system boot.I have also tried boot-repair-disk from USB disk,but it needs to run when the computer is in UEFI mode,but the USB disk is not being detected.

How can I make the computer to detect the USB disk in UEFI mode. How can I install ubuntu alongside windows 10

0

It was same happened with me but I have figured out the solution and successfully installed Ubuntu dual boot with Windows. And remember to disable fast startup in windows. For Doing this :-

  1. Goto Control Panel
  2. Hardware And Sound
  3. List item
  4. Power Option
  5. Choose What closing the lid does
  6. Change Settings Which Are Currently Unavailable
  7. At The Bottom Of The Page Uncheck Turn On Fast Startup.

Next Is To -:

  1. Don't Turn Off the UEFI mode otherwise it would be big headache for you later.The best option is to make USB bootable in windows 10 by using Win32Diskimager.

  2. Ubuntu 14.04 and 16.04 is signature checked OS so you need not turn secure mode off but in 16.04, in order to install 3rd parties application at the time of installation you'll need to turn secure mode off.

  3. Reboot the PC and goto the BIOS by pressing Esc key or other key according to your system.

  4. Turn Select UEFI mode then secure mode on/off according to your preference.

  5. Then Restart and press Esc key and select Boot Order and select your usb.

  6. Then you can live run it or install directly it. If you are able to do upto here then reply. I will tell you further according to the option you select. And Tell Me whether you have freed the partition space for the ubuntu?

Note - : In new Laptop if after installing Ubuntu the system may default loads into Windows. So either you can go into bios to select the boot order. The Ubuntu is displayed as seperated disk. Or Press boot menu button in the starting of your pc and select boot order as you are doing in case of selecting your usb drive.

-1

Try to check to boot from legacy mode and select boot from USB. Upon this selection your laptop should restart and quickly plugin your bootable USB. I have also encountered the same issue before. Playing around on bios startup fixed it.

Hope this works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.