I recently installed Kubuntu 15.04, mostly for the upgrade of KDE to KDE Plasma 5. I have been quite happy, but when I got back to school and plugged in my monitor I was very disappointed. Kubuntu is often not configuring my monitor properly. When I plug in the HDMI cable, I sometime get some sort of tearing (different views within the GUI are being scaled and displayed in distorted ways throughout both monitors). Sometimes, the viewport for the X server is enlarged, but the second monitor is turned off (this creates a panning situation with my single laptop monitor).

Lastly, whenever I remove my monitor, the X server viewport does not change size and I again have an issue of a huge viewport with a 1366x768 monitor (aka panning with the mouse). The extra edges on the viewport aren't usable, though. It's like KDE knows that there shouldn't be anything there, but displays it anyway.

In short, it half way initializes the monitor and when I get the monitor to work and unplug it, it only half way removes the monitor from the system. Plus, the odd tearing or malfunctioning rendering problems...

I've tried using the NVidia Server Settings and the built-in Display Settings module within System Settings to set the default actions, but it never works quite right.

If the monitor doesn't turn on and the viewport is resized, I can easily open NVidia Server Settings, turn it on, and voila, it works perfectly, but I shouldn't have to do that!

Any help is much appreciated. Thanks.


Try to run from Konsole this command:

    kcmshell5 kded

Stop and uncheck "KScreen 2" module, and then click on "Apply" and finally on "OK".

Connect the second display (probably nothing will happen in the second screen because you have disabled the display module), and go on:

System Settings > Display and Monitor, and enable the second display.

I hope you can solve like me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.