1

I got a problem with my Ubuntu phone. I have no icons on the "Apps"-Screen anymore after i did a reboot. I can only run applications wich are in the sidebar. When i close an application the phone reboots. I would like to reset my phone but i don't want to lose all my data, so i tried to connect it to my pc but the device is just not found.

I got Windows and Manjaro on my PC. I installed the android-tools-adb stuff o my Manjaro system but it can't see my device neither.

What can i try next ?

Greetz, Max

  • I pressed all three buttons on the side so the phone shuts down. Found this on another question. The icons are back but the phone does still reboot every time i close an application... :/ And i still can't get it connected to a pc – Enamrov Enamchan Aug 25 '15 at 19:47
  • I gave a partial answer to the USB problem. That's at least one for you, but that doesn't solve the main problem: rebooting when closing applications. Did you play around with a read-write root partition? I messed up my phone once that way. I couldn't even reach my app screen. That's a weird error, and I can't quickly find an answer to that. If all else fails, factory reset? – Maarten Klop Aug 28 '15 at 10:06
  • i am trying to do a factory reset right now following this introduction: askubuntu.com/questions/602834/… but it does not work for me yet becouse i can't get into the recovery mode. it only says "FASTBOOT mode" on the screen. Don't matter what button i press. nothing happens – Enamrov Enamchan Aug 29 '15 at 10:11
  • ok i managed to do a factory reset. But it did not help. Instead it became even worse. If i close an application now, the phone just freezes and i have to hold the power button until it reboots – Enamrov Enamchan Aug 29 '15 at 10:32
1

A search for 'aquaris usb' would have landed you at already answered question 602488, in which my answer was this:

Ubuntu touch does not allow USB interaction as long as the phone screen is locked. Even if it is only locked by slide, this can block the interaction. I also made sure my screen doesn't lock after idleness, so this locking doesn't happen halfway through a transfer.

Also, ~/.android/adb_usb.ini on your computer is a list of valid vendorIDs that are allowed to connect. I found that list empty (or non existent, don't remember, doesn't matter). Just add a new line with the vendorID for your phone: If you have MX4, add 0x2a45, if Aquaris E4.5, the ID is 0x2a47. Aquaris E5 probably the same. Otherwise look it up by using lsusb. You can of course also add both to be sure ;)

~/.android/adb_usb.ini :

0x2a45
0x2a47
  • I created the file as u said. I got the Aquaris E4.5 so i added a Line with 0x2a47. But adb still does not found anything yet – Enamrov Enamchan Aug 29 '15 at 10:19
  • i forgot to enable the developer mode :( that solved the problem now – Enamrov Enamchan Aug 29 '15 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.