0

Specs:

  • VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560] (rev a1)
  • Subsystem: ASUSTeK Computer Inc. Device 83b5
  • Kernel driver in use: nvidia
  • Ubuntu 15.04 - Linux-x86_64
  • NVIDIA Driver Version: 340.76
  • Hearthstone on PlayonLinux 4.2.8 using WINE 1.7.15

Hi, I've managed to get Hearthstone to work perfectly - except for a graphical glitch on the Blackrock Mountain game board. After a few moments on the board the shadows start to jump as if the light source changes as I move the mouse around. I've been cycling through the settings under the "Display" tab of PlayonLinux, but so far I've made no progress. I'm guessing it has to do with the nvidia drivers, but the terminal command 'nvidia-settings' doesn't give me much to work with. Any suggestions would be much appreciated.

EDIT: Recurring lines in wineprefix/hearthstone log file: (not sure if it reveals anything useful)

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

err:ole:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered err:ole:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1

Error: Invalid write to global property "_dotCount"

0

This is actually for problems with the battle.net launcher, but maybe it will help you as well to start with OpenGL? Unsure if it then changes launching Hearthstone as well...:

https://www.reddit.com/r/linux_gaming/comments/32u25q/battlenet_on_wine_not_working/cqempxt

3
  • Not sure how to implement the code provided. Would I have to edit and add the line to the 'Configure>General Tab>Arguments' segment on Play on Linux? It appears that wine_silverlight is/has been merged into wine-staging. The archlinux link leads to a 404. – Bys Aug 26 '15 at 12:40
  • @Bys: Yes, thats how I would do it. And put only '-opengl' in there of course. But again, I'm not sure if it helps your problem at all. – Jakob Lenfers Aug 26 '15 at 14:41
  • No effect. I have a hunch it's a nvidia driver setting that needs changing. Will have to read up on 'nvidia-settings.' Thanks for the suggestion. – Bys Aug 26 '15 at 14:52
0

It seems like I found the answer.

I had to update my NVIDIA driver to the latest version (352.41) and install Wine version 1.7.50 on the virtual drive through PlayonLinux. Rendering shadows is no longer a problem, but I do have some minor performance issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.