5

Apparently spotify needs libavcodec54 (or 53 or 52) to play local mp3 files. Unfortunately - it doesn't work with libavcodec56 which is in Vivid.

I tried symlinking libavcodec56 under name of *54, but it didn't work.

I also tried to compile from trusty sources, but it was failing too.

Is there any place or procedure that I could use to get working libavcodec54 for vivid?

2
  1. Download the neccessary deb files

    cd
    wget http://mirrors.kernel.org/ubuntu/pool/universe/o/openjpeg/libopenjpeg2_1.3+dfsg-4.7ubuntu1_amd64.deb
    wget http://mirrors.kernel.org/ubuntu/pool/universe/liba/libav/libavcodec54_9.18-0ubuntu0.14.04.1_amd64.deb
    wget http://mirrors.kernel.org/ubuntu/pool/universe/liba/libav/libavutil52_9.18-0ubuntu0.14.04.1_amd64.deb
    
  2. Install, in the order below

    sudo dpkg -i libopenjpeg2_1.3+dfsg-4.7ubuntu1_amd64.deb
    sudo dpkg -i libavutil52_9.18-0ubuntu0.14.04.1_amd64.deb
    sudo dpkg -i libavcodec54_9.18-0ubuntu0.14.04.1_amd64.deb
    

Tested in my Vivid system

% lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid

% apt-cache policy libopenjpeg2
libopenjpeg2:
  Installed: 1.3+dfsg-4.7ubuntu1
  Candidate: 1.3+dfsg-4.7ubuntu1
  Version table:
 *** 1.3+dfsg-4.7ubuntu1 0
        100 /var/lib/dpkg/status

% apt-cache policy libavutil52 
libavutil52:
  Installed: 6:9.18-0ubuntu0.14.04.1
  Candidate: 6:9.18-0ubuntu0.14.04.1
  Version table:
 *** 6:9.18-0ubuntu0.14.04.1 0
        100 /var/lib/dpkg/status

% apt-cache policy libavcodec54
libavcodec54:
  Installed: 6:9.18-0ubuntu0.14.04.1
  Candidate: 6:9.18-0ubuntu0.14.04.1
  Version table:
 *** 6:9.18-0ubuntu0.14.04.1 0
        100 /var/lib/dpkg/status
0

You can almost certainly just download the .deb file from the earlier version of Ubuntu and install it in parallel with the new one.

I've had to install older libraries in parallel with newer ones a few times for situations like this.

Try installing the deb from here:- http://packages.ubuntu.com/trusty-updates/amd64/libavcodec54/download

You may also need to install some other older libraries as dependencies tho.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.