Recently I've installed Ubuntu 15.04, everything had worked fine, but suddenly language change stopped working. I don't know what could be the cause of this, because I didn't notice it right away. Now, I've tried to assign different shortcuts to language change, I've tried to use language icon in the top right corner and simple reboot of course. Nothing seems to work. Could you please tell me what could be wrong and what can I do with it?

UPD: forgot to mention that in the top menu my second language(Russian) is present and I even can choose it, but when I type it's still English. UPD2: I've tried to add another language and even change order of input sources, but it didn't work out either. My input language is always English.

  • when you click on language icon on top menu , the last option is "text entry setting " ,click it . In input source can you see your language ? – Farimah Aug 25 '15 at 7:22
  • Yes, it's there. – Artem Malinko Aug 25 '15 at 7:24
  • refer here – Ravan Aug 25 '15 at 7:27
  • @Ravan I know how to add language. The problem is that it stopped working. – Artem Malinko Aug 25 '15 at 7:31
  • Ok @Artem before your edit I posted that comment – Ravan Aug 25 '15 at 7:33

1.I recommended you to read this Ubuntu documentation about "use alternative input source" .

It is explaining it step by step .

2.you can try reconfigure the keyboard configuration with this command

dpkg-reconfigure keyboard-configuration 

I hope it helps you.

  • No, still doesn't work after reconfiguration. – Artem Malinko Aug 25 '15 at 8:13
  • 5
    Hm, after several tries the second approach solved the problem. Although I still don't know how and what was the problem. Thank you! – Artem Malinko Aug 25 '15 at 8:26
  • I have the same issue after upgrading to 18.04. Running through dpkg-reconfigure seems, well, scary ― at least the rest of my keyboard input works now. – matt Jun 1 at 8:13

My problem was that the shortcut for change kept setting to "Shift L" or such. I couldn't get rid of the <Mod2>.

After trying dconf, gsettings, gconftool, gconftool-2 and other, I found out in other question that I have to turn off NumLock and set the shortcut again.

See https://bugs.launchpad.net/ubuntu/+source/unity/+bug/981628

  • 1
    Thank you! I also noticed the Mod2 but couldn't figure out what it is! Using Ubuntu 16.04 myself – s3v3n Apr 6 '17 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.