13

Recently I've installed Ubuntu 15.04, everything had worked fine, but suddenly language change stopped working. I don't know what could be the cause of this, because I didn't notice it right away. Now, I've tried to assign different shortcuts to language change, I've tried to use language icon in the top right corner and simple reboot of course. Nothing seems to work. Could you please tell me what could be wrong and what can I do with it?

UPD: forgot to mention that in the top menu my second language(Russian) is present and I even can choose it, but when I type it's still English. UPD2: I've tried to add another language and even change order of input sources, but it didn't work out either. My input language is always English.

6
  • when you click on language icon on top menu , the last option is "text entry setting " ,click it . In input source can you see your language ? – Farimah Aug 25 '15 at 7:22
  • Yes, it's there. – Artem Malinko Aug 25 '15 at 7:24
  • refer here – Ravan Aug 25 '15 at 7:27
  • @Ravan I know how to add language. The problem is that it stopped working. – Artem Malinko Aug 25 '15 at 7:31
  • Ok @Artem before your edit I posted that comment – Ravan Aug 25 '15 at 7:33
12

1.I recommended you to read this Ubuntu documentation about "use alternative input source" .

It is explaining it step by step .

2.you can try reconfigure the keyboard configuration with this command

dpkg-reconfigure keyboard-configuration 

I hope it helps you.

3
  • No, still doesn't work after reconfiguration. – Artem Malinko Aug 25 '15 at 8:13
  • 5
    Hm, after several tries the second approach solved the problem. Although I still don't know how and what was the problem. Thank you! – Artem Malinko Aug 25 '15 at 8:26
  • I have the same issue after upgrading to 18.04. Running through dpkg-reconfigure seems, well, scary ― at least the rest of my keyboard input works now. – matanster Jun 1 '19 at 8:13
4

My problem was that the shortcut for change kept setting to "Shift L" or such. I couldn't get rid of the <Mod2>.

After trying dconf, gsettings, gconftool, gconftool-2 and other, I found out in other question that I have to turn off NumLock and set the shortcut again.

See https://bugs.launchpad.net/ubuntu/+source/unity/+bug/981628

2
  • 2
    Thank you! I also noticed the Mod2 but couldn't figure out what it is! Using Ubuntu 16.04 myself – s3v3n Apr 6 '17 at 23:00
  • This works for me aswell, though I have to press NumLock every time before I can use the shortcut. – Labbsserts Jan 24 at 16:01
0

I have this exact problem with Ubuntu 20.04.1 LTS.

I don't know how to solve it and solutions above didn't work for me.

Still, there is a workaround: you can try adding another non-latin input source in "Region & Language" setting menu - I usually pick Albanian b/c it is easiest to add. Once I add it, switching to another input source starts working again and then newly added input source can be removed again - until this bug resurrects itself.


For what it is worth - I use standard keyboard that worked fine with the other linux distribution I had before switching to Ubuntu (Debian) and I didn't configure system in a non-trivial manner - the setup was fairly standard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.