0

I have installed Kubuntu 14.04 (desktop version). I wish to install Ethernet drivers. I have two ethernet ports and I found that the drivers that I need are e1000e and igb-5.2.13-k. I have downloaded the .tar.gz driver files from Intel website.

I have done the following steps:

tar zxf e1000e-3.2.4.2.tar.gz

cd e1000e-3.2.4.2.tar.gz

cd src

make install

It says

Makefile:121: *** Compiler not found. Stop.

What should I do?

Additional Information: I cannot use internet to do sudo apt-get (some packages) to install compiler or others. I have entered the IP, Gateway and I am able to ping the gateway nicely meaning there is no problem with the network connection. Only the Ethernet driver is not installed. Anyone have come across this?

0

If you can ping any Gateway, you don't need an ethernet driver, because ethernet is already working.

From what you described, I would say your network setup is just wrong. You most probably need to configure a proper routing setup so that your host knows how to get to the outside world. If available in your network, try first using DHCP.

Now, depending on the kind of Ubuntu setup you are running (Ubuntu, Kubuntu, pure server Ubuntu), you might want to review different articles for configuring that:

6
  • Thanks for your comments. I cannot ping www.google.com... What should I do?
    – Oliver
    Aug 25 '15 at 6:45
  • Sure, your host can't resolve hostnames yet. You need to tell it where your gateway and nameserver is. Please read up on your own about how to configure networking in Ubuntu. I can't do the reading for you.
    – Sebi
    Aug 25 '15 at 7:05
  • Thanks for your comment...I will read it...BTW i can ping 8.8.8.8
    – Oliver
    Aug 25 '15 at 7:12
  • That means even gateway is configured correctly. The only part missing is setting nameserver. In most cases, this is the same as gateway. But of course you could also use Google's nameserver under 8.8.8.8
    – Sebi
    Aug 25 '15 at 7:30
  • Thanks i edited the file resolv.conf and it is working nicely..
    – Oliver
    Aug 25 '15 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.