1

I have Lenovo Thinkpad Edge E430(32-bit) laptop. I have installed the 14.04 ubuntu version fresh rather than upgrading from the previous version. I am using this version for around 1 year. The wifi disconnection problem i am encountering from starting(after installing 14.04) itself. The wlan0 info is:

wlan0 IEEE 802.11bgn ESSID:"naruto"

      Mode:Managed  Frequency:2.437 GHz  Access Point: A0:21:B7:8B:A5:70   
      Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
      Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
      Power Management:off
      Link Quality=70/70  Signal level=-22 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:48   Missed beacon:0

Network Device Info is given below:

description: Wireless interface

   product: RTL8191SEvB Wireless LAN Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 10
   serial: f0:7b:cb:9f:11:09
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192se driverversion=3.13.0-62-generic firmware=N/A ip=10.0.0.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 ioport:2000(size=256) memory:f0500000-f0503fff

Problems: 1) When the system remain connected for ling time to wifi network around more than half an hour/sometimes hour, the wifi signal gets automatically disconnected(No weak signal issue as the wifi router is hardly 1m away and max 2 systems are connected to the router). After disconnection , the system is unable to connect to any wifi signal. The only solution is restart the system.

This problem is occurring very frequently.

2) Whenever i wake up the system from suspend state, the system doesnot able to connect to wifi network. The only solution is restart the system. This issue is always.

NOTE: Above both problems , after restarting the system, the system again connect the wifi signal successfully. But after long use it again disconnected. What to do?

1

First of all I suggest upgrading kernel by running

sudo apt-get install linux-generic-lts-vivid

If the problem persists after reboot, install a driver this way

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware
  • But the command sudo apt-get install linux-generic-lts-vivid install the linux kernel v3.19.0-26 which is not a stable or lts kernel(kernel.org). How can i install the latest stable or lts kernel version? My system have the current kernel version: 3.13.0-62-generic – Sanjeev Aug 25 '15 at 7:28
  • Kernel 3.19.0-26 is a stable Ubuntu kernel for 14.04.3 and 15.04. – Pilot6 Aug 25 '15 at 9:41
  • Thanks. The problem is resolved after upgrading to latest kernel version. – Sanjeev Aug 25 '15 at 15:57
0

I had the same problem. This worked for me.

I am using dual boot with Windows 10 I got a USB wifi adaptor and installed the drivers using Windows and connected to the internet with the USB adaptor. Then uninstalled the drivers and restart Windows,this will reset original drivers. That solved the problem. If you do not have dual boot then im not sure what you could do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.