4

It's still there, but it's invisible! Logging out makes it appear again, but logging out and back in after each boot is quite a nuisance. Any ideas?

Switching to Unity 2D seems to make the cursor appear when it's on the sidebar and topbar, but not when it's on the wallpaper or any applications

Also it appears that only the default pointer arrow cursor isn't showing: the hourglass cursor or finger cursors appear just fine! >:O

Tried changing the cursor theme following this guide - http://www.youtube.com/watch?v=2hu9JrdSXB8 - and even though the theme changed successfully, the default-state pointer is still invisble expect when on the side/topbar...

Having made a fresh install, the problem persists >:[

  • 2
    I am also having a similar problem. My mouse disappeared on random times. When i click it also disappear and then it shows up. Fav this question to see the solution from community. – Tahir Akram Oct 14 '11 at 23:28
  • +1 for the note about logging out and logging back in. That's a much nicer workaround than rebooting. – Planky Dec 15 '15 at 14:37
3

I had this problem on a Dell Optiplex 955. It has something to do with the video drivers and the default cursor set. You can set SWCursor on in your xorg configuration as discussed in this Ubuntu Forums post, however that has some performance impact (probably negligible on modern systems though).

What I did is edit /usr/share/icons/default/index.theme and changed DMZ-White to whiteglass (you can change it to any of the non-DMZ themes in /usr/share/icons with a cursor directory in its subdirectory like whiteglass or redglass)

After doing that, log out and back in to restart the X server.

| improve this answer | |
  • 1
    Thanks! I had trouble with the xorg.conf thing - there isn't a xorg.conf in my /etc/X11/ directory for some reason, and after I tried to add it myself and paste the code from the post in it, the login screen refused to show up at boot >:O I fixed that by deleting it again. Then I tried changing index.theme to whiteglass, redglass and some other, but neither of those worked - the default cursor wouldn't show anyway. But then I left the Inherits= value blank, rebooted, and poof! The cursor shows up every time now. Though it's black, but no matter: somehow, the problem is solved. Thanks! >:] – Fusha Oct 19 '11 at 10:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.