I erased my old Elementary OS and replaced it with Ubuntu 14.04.

I also have a Windows 7 install on a different drive, which was working fine under Elementary OS (which is based on Ubuntu 12.04) . However, the drive didn't get detected upon install and it is still not being detected.

I tried other similar responses but couldn't find a solution. This is the output of bootinfoscript http://paste.ubuntu.com/12179868/

So far, I tried:

Uninstalling and installing os-prober. Still same problem, no output when running it.

Creating a manual entry on /etc/grub.d/40_custom

menuentry "Windows 7" {  
     insmod ntfs  
     set root='(hd0,1)'  
     search --no-floppy --fs-uuid --set 94A47FB5A47F9906  
     chainloader +1  

Is the configuration correct? I run update-grub after editing the file but I get the error "Invalid EFI file path" when trying to boot it.

  • Is Windows a UEFI install? Aug 24, 2015 at 0:00
  • How do I figure that out?
    – Ezequiel
    Aug 24, 2015 at 3:14
  • It probably doesn't matter. Did you try running sudo update-grub to see if it'll find the Windows installation? Aug 24, 2015 at 3:18
  • Yes, I did after adding the menu entry for windows 7 manually but it only detects linux
    – Ezequiel
    Aug 24, 2015 at 15:04
  • 1
    UEFI & BIOS are not compatible. So from a UEFI install of Ubuntu you cannot boot BIOS install of Windows from grub, only from UEFI menu. And you may have to turn on/off UEFI & CSM/BIOS/Legacy mode for each system. You may be able to use one time boot key like f10 or f12 if system auto switches modes for each install.
    – oldfred
    Aug 24, 2015 at 16:35

3 Answers 3


I finally found a solution to my problem that didn't involve deleting my Windows partition. As other pointed out, the problem was that my Windows install was a legasy BIOS startup, while Ubuntu was now using UEFI, which is incompatible.

The solution was to convert Windows install to UEFI. The only required things were the Windows install dvd (or a booteable UEFI pendrive) and a working Ubuntu.

First, convert your Windows partition to GDP

sudo gdisk /dev/sdX
Command (? for help): w

where sdX is the windows drive.

Then, boot your Windows install disk and, from a Command Prompt, run the steps detailed on this link starting from step 7. This will replace the existing BIOS boot partition with a UEFI boot partition.

After these steps are done, you can run

sudo update-grub

to update your startup menu.


Use" fixmbr" command from Windows disc. It will remove grub. Then use Ubuntu live cd to restore grub. It should start working then.


I know, very old topic, but happened to me today. Putting the answer here, may help someone. In my case, the os-prober tool was missing, so the os-prober script in grub 2 would never find windows.

After installing it:

sudo apt-get install os-prober

I got i to finally work after updating grub:

sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Sourcing file `/etc/default/grub.d/60_mint-theme.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.0-53-generic
Found initrd image: /boot/initrd.img-5.3.0-53-generic
Found linux image: /boot/vmlinuz-5.0.0-32-generic
Found initrd image: /boot/initrd.img-5.0.0-32-generic
Found linux image: /boot/vmlinuz-4.15.0-101-generic
Found initrd image: /boot/initrd.img-4.15.0-101-generic
Found Windows 7 on /dev/sda1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .