0

I'm using xmodmap to disable the super key, but when i press some keys i.e. (M,A) the gnome shortcut for those keys (super+M, super+A) fires up, even without press the super key.

looks like the super key is virtually pressed even when it's disabled by xmodmap. this is my xmodmap file:

clear Lock
clear Control
clear Mod1
clear Mod2
clear Mod3
clear Mod4
clear Mod5

what can i do? i wanna use those keys normally.

0

Open Terminal and type:

xev

With the new window in focus, press the Super key to get its keycode. Since you say its virtually pressed, type the following:

xmodmap -pk

I did that and my key code is 133 for Super_L and 134 for Super_R, may not be the same so do a check.

To disable a key type the following:

xmodmap -e 'keycode <number> = NoSymbol'

I doubt one of the super key has the issue, so perform the command for one key and check if the issue is resolved.

  • still not working – moscoquera Aug 26 '15 at 14:51
  • Did you change both the super keys ? – araghuteja Aug 26 '15 at 15:03
  • yes, I did, I'm thinking the problem is in the "clear" command. – moscoquera Aug 26 '15 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.