1

I have Ubuntu 14.04 64bit. I am currently using Firefox which is present on the Unity panel (or launcher). The problem is that the icon is a question mark. I want to change it to the standard Firefox icon.

When i tried cat /user/share/applications/firefox.desktop |grep Icon

It says no such file or directory exists.

When i tried find /usr/share/icons -type f -iname '*firefox*'

It gave:

/usr/share/icons/HighContrast/48x48/apps/firefox.png
/usr/share/icons/HighContrast/16x16/apps/firefox.png
/usr/share/icons/HighContrast/scalable/apps-extra/firefox-icon.svg
/usr/share/icons/HighContrast/24x24/apps/firefox.png
/usr/share/icons/HighContrast/22x22/apps/firefox.png
/usr/share/icons/HighContrast/32x32/apps/firefox.png
/usr/share/icons/HighContrast/256x256/apps/firefox.png

I have tried to go to applications and follow the usual process but I could not find Firefox in applications. Please suggest some way.

  • 1
    Edit your question and add the output of cat /usr/share/applications/firefox.desktop | grep Icon – A.B. Aug 23 '15 at 18:38
  • 1
    And the output of find /usr/share/icons -type f -iname '*firefox*' – A.B. Aug 23 '15 at 18:39
  • have you tried reinstalling firefox? sudo apt-get install --reinstall firefox – mchid Aug 23 '15 at 22:16
  • Add the output of apt-cache policy firefox – A.B. Aug 25 '15 at 18:17
  • 1
    1. You misspelled /usr directory. The file should be /usr/share/applications/firefox.desktop 2. Mine says Icon=firefox. If that says the same (and still gives question mark ), you better download firefox icon from somewhere, like google images, and just set it manually. High contrast images you see up in the output of find are black-and-white iconds, non-standard – Sergiy Kolodyazhnyy Aug 26 '15 at 6:14
1

I have no idea what you've done or how you have installed firefox as there is no standard desktop file. Maybe you have removed Firefox earlier. Therefore re-install firefox

sudo apt-get install --reinstall firefox

Then, if still not the correct icon appears, remove the starter and add the starter again.

1

I have find a way :

1) connect yourself as root

2) go to /usr/share/applications

3) search for firefox

4) go to proterties and change the (missing for quantum) icon

5) Tell me if it's ok.

  • Hi Mc Lovin, and welcome to askUbuntu! Your post is not a new answer, respectively the same content was already posted. – abu_bua Jul 6 '18 at 22:00
  • 1
    Where ? I simply used a method that worked for me using the graphic tools. – Mc Lovin Jul 6 '18 at 22:19
  • You can find it in the comments. – abu_bua Jul 6 '18 at 22:29
  • 1
    @abu_bua A comment is not an answer. Maybe this could be a community wiki answer, or the comment's author should be asked to post an answer. Anyway, an answer should be an answer, not a comment. – Eric Carvalho Jul 7 '18 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.