0

I currently have a dnsmasq DNS server running on my desktop Ubuntu 15.04 installation. I use it to point to local devices on my network. For example, I have a record linking kerberos.dgourd.com to 192.168.1.106 (my desktop's IP address). However, this name never gets resolved.

I setup my router to hand out three DNS servers:

  1. 192.168.1.106 (My local DNS server)
  2. 8.8.8.8 (Two Google DNS servers)
  3. 8.8.4.4

On my laptop, also running Ubuntu 15.04, I ran nmcli dev show | grep DNS to make sure it is using the proper nameservers and got this:

IP4.DNS[1]:    192.168.1.106
IP4.DNS[2]:    8.8.8.8
IP4.DNS[3]:    8.8.4.4
IP4.DNS[4]:    192.168.1.1

Running dig kerberos.dgourd.com results in no record being returned:

; <<>> DiG 9.9.5-9ubuntu0.2-Ubuntu <<>> kerberos.dgourd.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 51586
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;kerberos.dgourd.com.       IN  A

;; Query time: 1 msec
;; SERVER: 127.0.1.1#53(127.0.1.1)
;; WHEN: Sat Aug 22 16:31:48 CDT 2015
;; MSG SIZE  rcvd: 37

However, running dig @192.168.1.106 kerberos.dgourd.com results in the proper record being returned:

; <<>> DiG 9.9.5-9ubuntu0.2-Ubuntu <<>> @192.168.1.106 kerberos.dgourd.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51972
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;kerberos.dgourd.com.       IN  A

;; ANSWER SECTION:
kerberos.dgourd.com.    0   IN  A   192.168.1.106

;; Query time: 5 msec
;; SERVER: 192.168.1.106#53(192.168.1.106)
;; WHEN: Sat Aug 22 16:36:05 CDT 2015
;; MSG SIZE  rcvd: 53

At this point, I'm completely stumped as to why this is happening. Sometimes, my computer will spontaneously start properly resolving these addresses, and then revert back to ignoring my DNS server. Does anyone have any suggestions on what I can do next to further investigate this isssue?

0

I believe it has something to do with NetworkManager controlling DNS and DHCP (via dnsmasq). If you can edit NetworkManager.conf in /etc/NetworkManager, and substitute dns=dnsmasq to dns=192.168.1.106, it should work. Restart the NetworkManager service before trying to use dig, of course.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.