0

This question already has an answer here:

I have recently installed Windows (10) on my Ubuntu (14.04) alongside after shrinking the root partition ( /dev/ubuntu-vg/root ) using GParted live (terminal) and rearranging the partitions using GParetd Partition Editor (GUI).

But now I cannot access root partition from Windows using Ext2Fsd. Here is my partition list.

enter image description here

/dev/ubuntu-vg/root is not in the Partition list and I think it is some where inside the /dev/sda5. Ext2Fsd identifies the file-system of this partition as RAW.

Please let me know if there is a way to access this Partition from Windows 10.

marked as duplicate by bain, Pilot6, David Foerster, Eric Carvalho, Charles Green Jan 21 '16 at 0:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This is not an Ubuntu question. IMHO you should ask at Windows sites how to access ext partitions. And also I am afraid that lvm partitions can't be accessed from Windows. And what is the point of accessing linux system partitions from Windows? – Pilot6 Aug 22 '15 at 19:27
  • I think Ubuntu community can help me with this. Some Ubuntu users may have experienced the same issue. And I am using Ubuntu as my Main OS therefore I have to access files in Ubuntu partitions (Specially Images and Videos) from Windows. (I am using softwares like Aftereffects) – Yasas Gunarathne Aug 22 '15 at 19:54
  • You can create an NTFS partition and share there files you need to acces both from Windows and Linux. Or do not use lvm. – Pilot6 Aug 22 '15 at 19:56
1

There is many ways to do it. This are the best two ways.

1- If you want to show the ext partition in my computer use "Ext2Fsd"

for download Click here

You can have Ext2Fsd launch at every boot or only open it when you need it. While you can theoretically enable support for writing to Linux partitions, I haven’t tested this. I’d be worried about this option, myself – a lot can go wrong. Read-only support is fine, though, and doesn’t have a risk of messing anything up.

If you didn’t set Ext2Fsd to autostart at boot, you’ll have to go into Tools –> Service Management and start the Ext2Fsd service before you can access your Linux files. By default, the driver automatically mounts and assigns drive letters to your Linux partitions, so you don’t have to do anything extra.

2- If you want to explore your ext partition in an app use "Ext2explore"

It’s an open-source application that works similarly to DiskInternals Linux Reader — but only for Ext4, Ext3, and Ext2 partitions. It also lacks file previews, but it has one advantage: it doesn’t have to be installed; you can just download the .exe and run it.

The Ext2explore.exe program must be run as administrator or you’ll get an error – you can do this from the right-click menu. To save some time in the future, go into the file’s properties window and enable the “Run this program as an administrator” option on the Compatibility tab.

As with Linux Reader, you’ll have to save a file or directory to your Windows system before you can open it in other programs.

For download Click here

  • Thank you for your answer @RonnieDroid but Ext2Fsd identifies the file-system of this partition as RAW. Do you have any solution for that? – Yasas Gunarathne Aug 22 '15 at 19:46
  • 1
    This is because of lvm. – Pilot6 Aug 22 '15 at 19:46
  • It seems there is no way to access logical volumes from windows @Pilot6 – Yasas Gunarathne Aug 22 '15 at 20:06
  • 1
    Ext2explore is unstable on windows 10 – Denja Jun 16 '16 at 13:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.