2

I am trying to install Ubuntu 14.04 from a CD over Windows Vista. I recently had a GPU failure on this machine, and while I was experiencing those problems (that made the computer unusable) I successfully booted Ubuntu from the live disc. I have bought and installed an AMD Radeon R7 370 and this has made my machine operable again but I would like to upgrade from Vista anyway.

When I attempt to either Install Ubuntu or simply boot from disc from the live disc menu, I get a blank screen that flashes a message saying "Invalid ROM contents" and then cuts to black, before sometimes restarting the computer in Vista.

I have searched around and it seems the full message (though I cannot see it on my screen) is "radeon 0000:01:00.0: Invalid ROM contents". I cannot find a solution to this problem - most answers seem to suggest it isn't fatal. I cannot seem to get past it though.

Thanks for any help!

  • Have you tried making a new LiveCD or even a LiveUSB? – TheWanderer Aug 22 '15 at 15:05
  • I have, same result except now a line saying [.. something off screen...]ailed appears before the invalid ROM contents, and then the screen goes blank with the left 7/8ths in Ubuntu mauve and the last 1/8th black. I'm assuming my screen is misaligned somehow but pressing enter and escape doesn't seem to do anything either. – Matt Costello Aug 22 '15 at 16:03
  • If your monitor has an auto adjust function I'd use that and wait. – TheWanderer Aug 22 '15 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.