1

I have setup my home server wrong I think, I have transmission for downloading my torrents it downloads to /mnt/external/Torrents/Finished if transmission downloads just a file to that folder everything is fine but if transmission downloads a file in a folder say "/mnt/external/Torrents/Finished/torrent-folder/torrent-file", then I access /mnt/external/Torrents/Finished/torrent-folder/torrent-file through samba share and try to move, delete torrent-file I get a permission denied? I'm not sure what I have done wrong and I'm a bit lost as what to check for my mistake?

Also if after downloading chmod -R 777 /mnt/external fixes the error but I have to do this every time. my fstab

UUID="5bae1949-1c8d-4ba2-857c-3febe56d3ef1" /mnt/external    ext4 rw,user,auto 0    0

my samba

[homes]
    browseable = no
    comment = Home Directories
    available = no

[external]
    force directory mode = 0777
    store dos attributes = no
    create mask = 0777
    hide dot files = yes
    public = yes
    inherit acls = yes
    browsable = yes
    writeable = yes
    inherit permissions = yes
    printable = no
    path = /mnt/external
    force create mode = 0777
    comment = External Drive
    directory mask = 0777
    available = yes
    read only = no

my /var/lib/transmission-daemon/info/settings.json

"lpd-enabled": true,
"max-peers-global": 3000,
"message-level": 1,
"peer-congestion-algorithm": "",
"peer-id-ttl-hours": 6,
"peer-limit-global": 3000,
"peer-limit-per-torrent": 3000,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": true,
"preallocation": 1,
"prefetch-enabled": 1,
"queue-stalled-enabled": true,
"queue-stalled-minutes": 30,
"ratio-limit": 0.2500,
"ratio-limit-enabled": true,
"rename-partial-files": true,
"rpc-authentication-required": true,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-password": "my-passwd",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "roo79x",
"rpc-whitelist": "127.0.0.1,*.*.*.*",
"rpc-whitelist-enabled": false,
"scrape-paused-torrents-enabled": true,
"script-torrent-done-enabled": false,
"script-torrent-done-filename": "",
"seed-queue-enabled": false,
"seed-queue-size": 10,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"trash-original-torrent-files": false,
"umask": 2,
"upload-limit": 100,
"upload-limit-enabled": 0,
"upload-slots-per-torrent": 14,
"utp-enabled": true
2
  • 1
    ...and what are the permissions of those folders??? Commented Aug 22, 2015 at 8:21
  • drwxrwxr-x 2 debian-transmission debian-transmission 4096 Aug 22 11:39 /mnt/external/Torrents/Finished/torrent1 drwxrwxrwx 3 roo79x roo79x 4096 Aug 22 12:28 /mnt/external/Torrents/Finished also debian-transmission has been added to roo79x and roo79x has been added to debian-transmission
    – Roo79x
    Commented Aug 22, 2015 at 8:43

1 Answer 1

2

I won't pretend to be able to make sense of the thicket of options you have given samba for the external HDD. Suffice it to say that I have a similar setup that works very well with just the following:

path = /...
force user = debian-transmission
read only = No
create mask = 0666
directory mask = 0777
veto files = /lost+found/
browsable = yes
guest ok = Yes

You may want to try that as a starting point, and then add more options as needed.

2
  • Same as for my setup though I have 0664 for file and 0775 for dirs.
    – Rinzwind
    Commented Aug 22, 2015 at 9:12
  • I just added "force user = debian-transmission" to my smb.conf and it fix the issue but I never had that before? still wondering what I have done wrong. Never had permission problems before I reinstalled ubuntu server, wish I could find the tutorial I used originally. anyways thanks everyone for the help. If you know of any good tutorials setting up transmission and samba shares please put them here... the help would be great
    – Roo79x
    Commented Aug 22, 2015 at 10:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .