1

I searched everyone online for solution, but it is still not working.

At first I changed the Nvidia driver to use the propriety driver from the additional tab, twice, and it shows black screen which cause me to reinstall.

And then I learnt about the alt+ctrl+f1 to show command prompt.

When I tested Dota 2 in Ubuntu with nouveau driver, there is some lagging. And when I tried it in my Linux Mint, it works smoothly. My mint is using propriety driver.

So I decided to try to change it again on my Ubuntu. And Voila! Blackscreen ? Seriously such a popular distro can have so many bugs? For example like suspending and not waking up? I could just change the driver in Additional Driver tab in Mint without problem but not Ubuntu?

So I tried many times purging it, installing dkms, downloading drivers from Nvidia sites, all sort of method. Sometimes it shows black screen, sometimes login loop, sometimes logged in but no Unity, but I can right click open terminal and use the terminal though.

Seriously anyone got a proper solution for this? I updated and installed everything in my Ubuntu properly already I do not hope for a need to reinstall. Thanks.

I'm Using Ubuntu 15.04

Nvidia GeForce GTX 860X

Intel i7-4720HQ with graphical in it

prime-select query shows

nvidia

xorg.conf file is default, not changed when booted up.

Actually I did try to change back to nouveau but it does not load Unity, probably because I'm using Compiz? But now I'm trying to get Nvidia driver to work!

EDIT : Now my Nvidia version is 346, from default repository. Still black screen

EDIT: I successfully changed back to nouveau and enable Unity through CCSM. Nvidia drivers are not working at all!

0

Install the drivers by running in terminal or console

sudo apt-get install nvidia-346 nvidia-prime

To get to console you can press Ctrl+Alt+F1, login there and run this command, then

sudo reboot
  • Oh, how I wish that would be functional for me. I usually get a black screen or a nonfunctional GUI login screen (typing not possible). – Hannu Aug 21 '15 at 14:23
  • I added explanation how to run it. – Pilot6 Aug 21 '15 at 14:30
  • Well, I have tried it both forwards and backwards - and only find it to be totally impossible to fault find. – Hannu Aug 21 '15 at 14:36
  • It is not backwards or forwards. You need to press them simultaneously. – Pilot6 Aug 21 '15 at 14:37
  • simply doing this would just get me a black screen. – Timothy Aug 21 '15 at 14:39
0

Which version of Xorg are you using? If it is >= 1.17.2 then you probably have the same problem I had with NVidia and PRIME.

Gigabyte Notebook with hybrid Intel + Nvidia GTX 765M card with PRIME not working with (K)Ubuntu 16.04 with any version of the proprietary NVIDIA driver. When prime-select switched to nvidia gives a black screen, set to intel worked. NVidia proprietary driver prime-select set to nvidia worked on (K)Ubuntu 14.04 before.

The solution that worked for me (with latest stable driver 367.57, from graphics ppa, but should work with every driver) was to change xorg.conf!

The version of Xorg shipped with (K)Ubuntu 16.04 is 1.18.4, where the BusID format in xorg.conf was slightly changed in Xorg >= 1.17.2. I changed BusID "PCI:1@0:0:0" on the nvidia card to BusID "PCI:1::0:0" and similar process on the intel section and also added the LoadModule setting. Like described in an answer to a post on askubuntu. see: https://askubuntu.com/a/776527

I guess the broken id works on PRIME set to intel because autodetection in single-intel mode is much better then the Nvidia PRIME stuff.

After restart it worked, but something changed my xorg.conf again to have invalid data. I'm now experimenting with deactivating gpu-manager by commenting all lines in /etc/init/gpu-manager.conf (see https://vxlabs.com/2015/02/05/solving-the-ubuntu-14-04-nvidia-346-nvidia-prime-black-screen-issue/ ) and setting "chattr +i" for xorg.conf.

and see ArchWiki: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

Hope this solves your problems with NVidia PRIME too!

0

I solved it.

Try to manually change the graphic driver using GUI (Nvidia Bee).

  • This answer is somewhat ambiguous. What GUI? Did you mean Settings > Additional Drivers (part of software-properties-gtk)? Better to mention that so other users can clarify. – clearkimura Dec 16 '16 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.