On my 11.10-running desktop, Unity 2d seems to work, Unity 3d does not. I ran a test, and here is what I got.

Not software rendered:    no  
Not blacklisted:          no  
GLX fbconfig:             yes  
GLX texture from pixmap:  no  
GL npot or rect textures: yes  
GL vertex program:        yes  
GL fragment program:      yes  
GL vertex buffer object:  yes  
GL framebuffer object:    yes  
GL version is 1.4+:       yes  

Unity 3D supported:       no

So, since I don't know much about what this means, can someone tell me what they mean, and how I can fix it (if I can). I plan on replacing this computer (which is seven years old) next year, but in the meantime, can I have some help? Also, with those results, can I run Gnome Shell?

PS: The code for the test was /usr/lib/nux/unity_support_test -p


According to the specs I see about a D2400 it has an Intel i845 video driver, which I'm afraid isn't enough to run either Unity 3D or GNOME Shell.


If you replace your window manager with Compiz using compiz --replace it will start Unity 3D whether they like it or not. On my Dell D820 which is also blacklisted, it runs just fine.


I don't think your computer supports it then. I looked up the computer and it is an old model. I don't think Unity 3D will be supported on this machine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.