0

My ageing PC running Mint 17 (based on Ubuntu 14.04) has been working fine for years, with everything working perfectly for me. However I have a problem whenever I add a new user, which I have to do frequently. The LC_TIME part of the locale always defaults to Spanish, presumably because my time zone is "Europe/Madrid." The down side to this is that the dates are always in Spanish, everything else in UK English, whereas the date for me (the user created during installation) is shown correctly in English. There is a workaround here but do I really have to do this every time I add a user? What would be better is the ability to customize the DEFAULT locale settings so that they are inherited at creation time. Screenshot

In the screenshot you can see that the LANG and LC_TIME are different. The output from the command "locale" is different for me and any new user I create, which is where (I think) the problem is.

BTW the /etc/default/locale file is as follows:

LANG="en_US.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LC_MONETARY="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_ADDRESS="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"

but as my sign in gives en_GB.UTF-8 (which is what I want), something clearly changes it. What is it, and how do I fix this problem?

1

You need to change /etc/default/locale. The easiest way is to open Language Support and select the Regional Formats tab. You'll probably find English (United Kingdom) preselected, since that's what you have for your own user. To make it default for new users, just click the Apply System-Wide button.

2
  • Thanks for the response. I included the screenshot to try and give as much information as possible, and you can see there that the English UK option is already selected and has been applied system-wide, but it does not fix the problem - the /etc/default/locale file does not change and new users still inherit the Spanish "en_US.UTF-8." I wish it was that simple, it has been driving me nuts for ages. – Scooby-2 Aug 21 '15 at 20:33
  • @Scooby-2: Your screenshot seems to be from the Language tab of Language Support, while I was talking about the Regional Formats tab. OTOH it looks like somebody has modified the tool (which is an Ubuntu tool) for Mint - maybe they screwed up something. So I guess you'd better edit /etc/default/locale manually, then, and replace all occurrences of es_ES.UTF-8 with en_GB.UTF-8. – Gunnar Hjalmarsson Aug 21 '15 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.