1

My Dell XPS (with ubuntu preinstalled on it, EDIT1: it was bought on 2014 June-July) does not start. Pressing power on button, a black screen is showing this text:

Missing operating system.
Operation System not found

I was thinking to restore grub (I don't even know if it is installed) using boot-repair from a live usb, but when I try to start any ubuntu image among ubuntu 12.04, ubuntu 15.04, boot-repair-disk, those aren't starting, remaining frozen on ubuntu splash screen.

I tried to start from an usb device dell-12.04.2_20130822_0809.iso too, but this image stops on a command prompt having the label initramfs.

I also tried Super Grub2 Disk from Ultimate Boot CD, without success (maybe I am missing something).

Does anybody have suggestions?

PS. I checked out from the BIOS if UEFI mode was enabled and it turned
    out that it is NOT enabled: is this common for a DELL XPS?


EDIT2: Trying to enable UEFI returns a black screen with this text:

       No bootable devices - strike F1 to retry boot, F2 for setup utility.
       Press F5 to run onboard diagnostics.

EDIT3:

Using gparted from a live usb (I finally booted an ubuntu 15.04 distro), as @Buck said, I found out that file system was not properly recognized (maybe damaged). I used fsck to repair damaged file system, and finally booted the system successfully, except for wi-fi card that stopped working.

  • 1
    I don't know offhand if pre-installed Ubuntu Dell XPS laptops ship with Ubuntu installed in BIOS or in EFI mode. This may well vary depending on the age of the laptop, which you haven't specified. Another emergency-boot tool you might try is my own rEFInd boot manager. Its USB flash drive or CD-R images should boot Ubuntu pretty easily, provided Secure Boot is disabled. If that works, you can at least begin debugging the problem from a full installation. – Rod Smith Aug 20 '15 at 17:01
  • The laptop was bought last year (2104) in June-July. Since I'm from Windows, is it correct to use UNETBootin to create an usb device within your rEFInd boot manager? – Filippo Lauria Aug 20 '15 at 17:06
  • Did you try to enable UEFI? – Buck Aug 20 '15 at 17:27
  • @Buck this is what appears: No bootable devices - strike F1 to retry boot, F2 for setup utility. Press F5 to run onboard diagnostics. – Filippo Lauria Aug 20 '15 at 17:51
  • Do you have another USB flash or drive, or another HDD to try to install to? Even if it is only a 4GB flash drive. – Buck Aug 20 '15 at 18:35
1

Here are a couple of things to try:

Boot to a Live USB to make sure you still have data, etc. on your main drive. Use Gparted to make sure the boot flag is still there. Use Gparted to create a small 4GB or so partition and reinstall Ubuntu to that partition, or to another drive, internal or USB. (I did this once and accidentally repaired a non-booting drive.)

Edit:

If you have a separate partition for /home, you could try reinstalling Ubuntu on top of where you already installed it. Your /home will be preserved as long as you don't format it in the process.

  • Using gparted i can see that on /dev/sda3 ther is partition with File System: unknow with size 220 GiB.. it has boot flag also.. is the entire file system corupted? – Filippo Lauria Aug 20 '15 at 18:05
  • It doesn't look good, but I haven't given up yet. See my comments on the original question and we'll see what we can do. It will take some time. – Buck Aug 20 '15 at 18:37
  • I partially solved using fsck -a /dev/sda3. Partially beacuse now I can boot ubuntu, but for some strange reason wifi card is no longer working. – Filippo Lauria Aug 20 '15 at 22:09
  • Ok, that's an improvement. Are your document data there? If so, can you back them up anywhere? – Buck Aug 20 '15 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.