0

I'm triple booting Ubuntu, Windows 7, and Mountain Lion from a single hdd in my Macbook Pro 5,3. Somehow, when I got everything set up, I had two options to boot Windows from rEFInd: one that read "boot Windows from WINDOWS" (which I'd named the partition I installed Windows on) and one that read "boot Windows from LINUX" (the partition I used for Ubuntu. Oddly enough, the first option brought me to the GRUB menu (which had options for booting Ubuntu and Mountain Lion, but not Windows), while the second option actually let me boot Windows. A few weeks back I upgraded GRUB as part of Ubuntu's updates. Now both Windows boot options take me to GRUB, which lacks an entry for booting Windows. Mind you, my Windows partition still exists, the files are still there, and I can boot it from a virtual machine without a problem.

  • Please run the Boot Info Script (available in the boot-info-script package in Ubuntu). This will produce a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. Also, please show the output of ls /sys/firmware when you're booted into Ubuntu. – Rod Smith Aug 20 '15 at 13:17
  • I have pasted everything you mentioned here: paste.ubuntu.com/12183246 – burningserenity Aug 24 '15 at 12:47
1

It looks like you've got a BIOS-mode version of GRUB installed to your hard disk's MBR, and it's getting confused about how to boot Windows. Your /sys/firmware directory's contents indicate that you've booted Ubuntu in EFI mode, so I'm guessing you're booting your Ubuntu kernels directly from rEFInd, thus bypassing GRUB. In other words, GRUB is useless to you. Unfortunately, completely removing GRUB is tricky, since Ubuntu will try to add it back. You can probably minimize the damage it can do by switching to an EFI version of GRUB, though:

sudo apt-get install grub-efi

This should cause the BIOS version of GRUB to be uninstalled, so subsequent updates shouldn't cause more grief; but you may end up with an extra GRUB boot option in rEFInd's menu. Installing the EFI-mode GRUB alone will not solve your problem, though. For that, you'll need to use a Windows recovery disk to re-install the Windows BIOS-mode boot loader. You may be able to use your Windows installation medium for this. If not, repair disc images are available from Microsoft. Unfortunately, I have neither direct download links nor explicit instructions of what you must do to fix this; but doing a Web search on re-installing the Windows boot loader should turn up some options.

With any luck, this will get you booting, but you may have extra options in the rEFInd menu. You can hide these by using the dont_scan_volumes, dont_scan_dirs, and/or dont_scan_files options in refind.conf. Read their descriptions in the configuration file itself for information on how to use them. You'll have to pay attention to the item descriptions presented in rEFInd when you highlight an option to figure out what to pass as options to the dont_scan_* tokens.

  • Thank you, I'll try that and let you know how it goes. For now, I seem to have another problem preventing me from installing anything through apt-get. – burningserenity Aug 31 '15 at 13:08
  • Thanks again! I can see in RESULTS.txt where it clearly says I had a BIOS version of GRUB, but how did you surmise that my MBR was missing? – burningserenity Sep 1 '15 at 13:14
  • Your MBR is not missing, nor did I say it was. (The MBR is simply the first sector on the disk. It normally contains an MBR partition table and often a BIOS-mode boot loader.) The one reference to MBR in my answer was in my first sentence, where I wrote that a BIOS-mode GRUB is installed there. This information appears near the top of the Boot Info Script summary: Grub2 (v1.99) is installed in the MBR of /dev/sda. (Only BIOS-mode boot loaders install to the MBR, so this GRUB must be BIOS-mode.) – Rod Smith Sep 1 '15 at 13:20
  • Whoops. So much for my reading comprehension. – burningserenity Sep 2 '15 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.