I wanted to use fcitx as the input method framework in Xubuntu desktop and made the changes using im-config. After the change I restarted X Server and can't get into desktop. I tried rebooting, switching back to previous input method (ibus) which is chosen automatically, using alternative desktop environments (I have also Ubuntu unity and Lubuntu installed), nothing worked. Can someone give me some ideas as to where to check and how to fix this? I really don't want to re-install this box (it's a VM).

  • .xsessionerrors file says: – Max Aug 20 '15 at 5:38
  • .xsessionerrors file says: openConnection: connect: No such file or directory cannot connect to brltty at :0 However nothing described in: askubuntu.com/questions/423725/ubuntu-12-04-32bit-cant-login worked for me. – Max Aug 20 '15 at 5:38
  • Exactly what did you do when you "made the changes using im-config"? – Gunnar Hjalmarsson Aug 20 '15 at 16:44
  • Yes. I ran it several times. First time I chose "auto" because it was the recommended option. It chose IBus, which is not what I wanted. So I ran it again manually choosing "fcitx". I couldn't turn my IME on so I restarted the system. That was when I could not enter desktop. I switched to console by Ctrl+Alt+F1 and ran im-config for another several times in text mode, choosing "auto" (which ended up with IBUS) and IBUS, however nothing helped. – Max Aug 20 '15 at 23:52

For normal use, you should never need to call im-config manually in the first place. Switching between IBus and fcitx is best done using Language Support.

Anyway, you did. If you are reasonably sure that the problem is caused by your "messing" with IM settings, I'd suggest these steps:

  1. Open a console window with Ctrl+Alt+F1 and log in.

  2. Run these commands:

    rm .xinputrc
    sudo apt-get purge im-config
    sudo apt-get install im-config
    sudo apt-get install xubuntu-desktop
    sudo reboot

Please note that purging im-config will likely result in the removal of a bunch of other packages. You need to accept that. Re-installing xubuntu-desktop should put those packages (at least most of them) back in place.

  • It worked! I was even ready to do a recovery reinstallation. Thank you su much Gunnar! – Max Aug 21 '15 at 0:56
  • @Max: Very glad to hear that. To be honest, I wasn't quite sure it would help you. – Gunnar Hjalmarsson Aug 21 '15 at 1:01
  • it doesn't work if im on ubuntu and do sudo apt-get install ubuntu-desktop for that last command? – user2167582 Feb 9 '16 at 0:42
  • @user2167582: What is it that doesn't work? Please note that my answer was in response to the specific situation as described in the question. – Gunnar Hjalmarsson Feb 9 '16 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.