Looked high and low - but not able to get a clear cut answer / leads.

I am using 14.04 for file server. There are 4 users connected to this - each with their own pwds. All are shared to one group.

The file create and directory create mask are set to 0777 - thus it should be that each file and folder is shared to all other users. But it is not working like this.

I have also enabled recycle bin in the samba settings.

Would be grateful for some hints.


  • make sure you have changed ownership of shared directory to new group that you create and also changed permission and all user should be member of this group . please provide behavior that you are getting that will be better for me to understand your problem .
    – pl_rock
    Aug 20, 2015 at 5:43
  • The folder created by any one user is read only for other users. Except folders created by xx - where xx is the group owner.
    – user128246
    Aug 20, 2015 at 9:51

1 Answer 1


Hi this might probably fix your issue https://help.ubuntu.com/community/Samba/SambaServerGuide grts

  • Yes. I have looked at all these documentation before posting here.
    – user128246
    Aug 20, 2015 at 5:05
  • Did the other ones the same in file sharing as well ? howtogeek.com/74459/…
    – Des Coene
    Aug 20, 2015 at 5:27
  • I have added the users as explained in the howtogeek article. the same settings were working earlier in 12.04. now we are having to change permissions again and again manually.
    – user128246
    Aug 20, 2015 at 9:49
  • Well i could n´t come up with a better idea to assist a bit, but in a home network or a network environment there has always been the same file share settings configured to share properly,it is not the same as file sharing over cloud i hope you could establish the file sharing like you want it to be
    – Des Coene
    Aug 20, 2015 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.