1

I am experiencing a dual monitor problem using .xprofile to change DVI screen resolution.

I am running Ubuntu 14.04.3 Trusty Tahr in dual screen mode. Primary screen output is HDMI; other screen outputs DVI. HDMI output (1600x900+0+0) is not a problem. DVI (1368x768+1600+0) screen causes problem. The DVI monitor is Dell IN1910Nf(2009) DVI-0 1366x768_60.00 which outputs 1024x768 60.0 as highest resolution available (xrandr). So I added a --newmode using xrandr and created a new ~/.xprofile file in /home dir. But the DVI output changes to 1280x768@60Hz instead of 1368x768@60Hz. Video display does not cover entire screen. .xprofile does some thing, but the wrong thing.


The --newmode config works great per session, but I hoped .xprofile would be a permananent fix.

cvt 1368 768 60 returned... (1366 768 60 returns same)

1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

Added New Mode: xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

Applied New Mode to DVI Port: xrandr --addmode DVI-0 "1368x768_60.00"

Applied New Mode to Screen Output: xrandr --output DVI-0 --mode "1368x768_60.00"

(all of the above works per session)

Created X profile file in root: gedit ~/.xprofile

Added code to new ~/.xprofile: xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync xrandr --addmode DVI-0 "1368x768_60.00" xrandr --output DVI-0 --mode "1368x768_60.00"

After OS restarts, DVI-0 output changes to "1280x768@60Hz" instead of xrandr --newmode "1368x768_60.00" in ~/.xprofile It does change the resolution, but the size again is wrong.


Note: Once unity-control-center display settings have been applied, the xrandr fix no longer works.

Reference URL:

Ubuntu Wiki - X Config Resolution https://wiki.ubuntu.com/X/Config/Resolution

  • [Solved] xvba-va-driver XvBA-based backend for VA API (AMD fglrx implementation) solved my dual-head config problem. unity-control-center display named the DVI monitor Unknown Display but the correct resolution, 1366 x 768 (16:9), was listed in the pull-down menu, which means fixed as far as I'm concerned. – noobninja Aug 22 '15 at 22:03
  • But the output of other resolutions in pulldown menu do not always fill the screen. xvba-va-driver installs fglrx (proprietary; no updates) without Catalyst configuration GUI. lspci | grep VGA returns 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850] – noobninja Aug 22 '15 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.