6

I know there are many questions on this site about wifi issues but I have searched and can't see to find an answer to mine. So here is the deal, a few weeks ago my house got a new router and since then Ubuntu has not only had trouble connecting to that router, but all wireless networks. I usually cannot connect immediately upon start up (wifi will try to connect, fail, then keep trying this over and over). I usually take these steps to get connected:

  1. Enable wifi/networking.
  2. Edit my connections, delete the known wireless network, reconnect.
  3. sudo service network-manager restart in the terminal
  4. a mixture of these 3

I can usually get it to connect using these methods, but once I connect I get about a solid 5 - 15 minutes of connection then my internet will go out again. The strange thing is, when my internet goes out Ubuntu still says I'm connected. I know it is not my wifi because my room mates do not have any of these issues. Can any of you help? I'm desperate.


Forgive me for formatting, but here is my output:
lspci -knn | grep Net -A2

02:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] [8086:0091] (rev 34)
    Subsystem: Intel Corporation Centrino Advanced-N 6230 AGN [8086:5201]
    Kernel driver in use: iwlwifi
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Aug 19 '15 at 12:58
  • Output added to post, I'm sure the formatting is off. – Brett Barbara Aug 19 '15 at 13:26
7
+50

You can fix it by running in terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1"

then reboot.

You can revert it by sudo rm /etc/modprobe.d/iwlwifi-opt.conf.

To keep the 802.11n, you can try the 11n_disable=8 option.

  • Just rebooted and it connected right at start up for the first time since we got this router! Thank you!! – Brett Barbara Aug 21 '15 at 18:35
  • 1
    At last, thank you! Works also for Intel Corporation Centrino Advanced-N 6235. – Metaxal Nov 5 '16 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.