1

I now know it is not a DNS issue, because I can't even ping 8.8.8.8. I've added the output of tracepath 8.8.8.8.

My machine running the most up-to-date version of 14.04 Trusty. The mobo has two ethernet ports and a Wi-Fi card. Both ethernet ports are plugged in. One goes directly into the router and has a static IP address. The other is plugged into a network switch and is DHCP. This machine was a fresh installation and has had DNS issues from the get-go. It's located in Texas, I'm in Denver, and I am controlling it remotely through Teamviewer so I know some outgoing/incoming traffic gets through. Other machines on the same network have no networking issues.

Symptoms:

  • Cannot load websites by name (google.com) or IP (64.233.177.103)
  • Cannot use sudo apt-get, times out connecting to servers
  • Cannot ping WAN IPs. Pinging 8.8.8.8 gets no response and 100% packet loss.
  • Can ping LAN IPs.
  • Can load router config page in web browser through LAN IP.
  • Allows Teamviewer remote connection. UDP does not seem to work, TCP works ok but I get kicked out regularly.

Troubleshooting steps taken so far:

  • Power cycled machine
  • Unplugged/Replugged both network cables
  • Changed connection type to DHCP, and back to static, for both ports through network settings GUI. Currently one is static and the other is DHCP.
  • Factory defaulted router and upgraded to latest firmware (Luxul XBR-4400)
  • Restarted Networking Service
  • Restarted network-manager
  • Tried adding static IP manually through /etc/network/interfaces. Made it match what I had set through GUI.
  • Bypassed local nameservers per this answer: Should I edit my resolv.conf file to fix wrong DNS problem?
    • This involved commenting out the dns=dnsmasq line in /etc/NetworkManager/NetworkManager.conf.
    • Running Sudo restart network-manager changed my /etc/resolv.conf file

from this:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
search lan

to this:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.8.1
nameserver 75.75.75.75
nameserver 8.8.8.8
search lan
  • I still get the same exact symptoms. DNS and static IP's have been configured through GUI.

Running nslookup www.google.com gets me a normal looking output, so nslookup seems to work (along with Teamviewer). However loading www.google.com or a direct IP for www.google.com (64.233.177.147) does not work.

Output of nslookup www.google.com:

Server:     192.168.8.1
Address:    192.168.8.1#53

Non-authoritative answer:
Name:   www.google.com
Address: 64.233.177.147
Name:   www.google.com
Address: 64.233.177.104
Name:   www.google.com
Address: 64.233.177.99
Name:   www.google.com
Address: 64.233.177.105
Name:   www.google.com
Address: 64.233.177.103
Name:   www.google.com
Address: 64.233.177.106

Output of /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Output of nmcli dev list iface eth0 (eth0 is static)

GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           802-3-ethernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        Motherboard
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               rtl8168g-2_0.0.1 02/06/13
GENERAL.HWADDR:                         FC:AA:14:E5:55:DD
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.3/0000:04:00.0/net/eth0
GENERAL.IP-IFACE:                       eth0
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     /org/freedesktop/NetworkManager/ActiveConnection/3
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     1000 Mb/s
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{0}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   29935289-bf46-4dcf-89a0-b282fa8b3f69 | Wired connection 2
WIRED-PROPERTIES.CARRIER:               on
IP4.ADDRESS[1]:                         ip = 192.168.8.99/24, gw = 192.168.8.1
IP4.DNS[1]:                             192.168.8.1
IP4.DNS[2]:                             75.75.75.75
IP4.DNS[3]:                             8.8.8.8

Output of nmcli dev list iface eth1 (eth1 is DHCP)

GENERAL.DEVICE:                         eth1
GENERAL.TYPE:                           802-3-ethernet
GENERAL.VENDOR:                         Intel Corporation
GENERAL.PRODUCT:                        Ethernet Connection I217-V
GENERAL.DRIVER:                         e1000e
GENERAL.DRIVER-VERSION:                 2.3.2-k
GENERAL.FIRMWARE-VERSION:               0.13-4
GENERAL.HWADDR:                         FC:AA:14:E5:55:DB
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:19.0/net/eth1
GENERAL.IP-IFACE:                       eth1
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     /org/freedesktop/NetworkManager/ActiveConnection/2
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     1000 Mb/s
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{2}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   117aa4b3-1265-468e-b07d-d3c8998b14ea | Wired connection 1
WIRED-PROPERTIES.CARRIER:               on
IP4.ADDRESS[1]:                         ip = 192.168.8.141/24, gw = 192.168.8.1
IP4.DNS[1]:                             192.168.8.1
IP4.DOMAIN[1]:                          lan
DHCP4.OPTION[1]:                        host_name = nimbus-NS150
DHCP4.OPTION[2]:                        domain_name = lan
DHCP4.OPTION[3]:                        expiry = 1439959400
DHCP4.OPTION[4]:                        broadcast_address = 192.168.8.255
DHCP4.OPTION[5]:                        dhcp_message_type = 5
DHCP4.OPTION[6]:                        dhcp_lease_time = 43200
DHCP4.OPTION[7]:                        ip_address = 192.168.8.141
DHCP4.OPTION[8]:                        subnet_mask = 255.255.255.0
DHCP4.OPTION[9]:                        dhcp_renewal_time = 21600
DHCP4.OPTION[10]:                       routers = 192.168.8.1
DHCP4.OPTION[11]:                       dhcp_rebinding_time = 37800
DHCP4.OPTION[12]:                       domain_name_servers = 192.168.8.1
DHCP4.OPTION[13]:                       network_number = 192.168.8.0
DHCP4.OPTION[14]:                       dhcp_server_identifier = 192.168.8.1

Output of ifconfig -a:

eth0      Link encap:Ethernet  HWaddr fc:aa:14:e5:55:dd  
          inet addr:192.168.8.99  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::feaa:14ff:fee5:55dd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:331544 errors:0 dropped:2390 overruns:0 frame:0
          TX packets:132548 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:43753936 (43.7 MB)  TX bytes:67745643 (67.7 MB)

eth1      Link encap:Ethernet  HWaddr fc:aa:14:e5:55:db  
          inet addr:192.168.8.141  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::feaa:14ff:fee5:55db/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:839361 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1113669 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:85882847 (85.8 MB)  TX bytes:427516880 (427.5 MB)
          Interrupt:20 Memory:f7e00000-f7e20000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2373781 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2373781 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:623910191 (623.9 MB)  TX bytes:623910191 (623.9 MB)

wlan0     Link encap:Ethernet  HWaddr ac:fd:ce:47:1e:77  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Pinging my router:

PING 192.168.8.1 (192.168.8.1) 56(84) bytes of data.
64 bytes from 192.168.8.1: icmp_seq=1 ttl=64 time=0.308 ms
64 bytes from 192.168.8.1: icmp_seq=2 ttl=64 time=0.227 ms
64 bytes from 192.168.8.1: icmp_seq=3 ttl=64 time=0.220 ms
^C
--- 192.168.8.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.220/0.251/0.308/0.043 ms

Pinging 8.8.8.8:

nimbus@nimbus-NS150:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
^C
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3022ms

tracepath 8.8.8.8

1?: [LOCALHOST]                            pmtu 1500
1: Luxul.lan                                 0.485ms
1: Luxul.lan                                 0.502ms
2: no reply
3: no reply

To sum it up: LAN DNS seems to work fine. DNS settings look correct (as far as I can tell). WAN DNS does not work. However remote desktop software such as Teamviewer is semi-functional.

Thanks for your help, Jeff

0

First off all: thanks for a very elaborate question! :-)

Couple additional ones (question/remark):

  • is the switch (where LAN-interface is connected to) connected to the router as well? I ask this because LAN- and WAN-address are in the same "network" 192.168.8.x ? This might create packet-loops (ie. router gets request from LAN-ip for web, wants to return answer through shortest path to host, being WAN-ip, PC doesn't know what to do?)
  • Your "WAN DNS" is working, nslookup works? "WAN Ping" is a different story.

Second, I would do this:

Put WAN-interface on DHCP, edit the router to always hand out the same IP-address to the MAC-address of said WAN-interface.

Put LAN-interface on Static, and DON'T add gateway. That way, all internet-related traffic is forced to WAN-interface.

Regards.

  • Thanks for the reply! - The switch is connected to the router, it's an unmanaged switch so the whole network is managed by the router. The idea was to have a more robust connection with 2 network ports, but it may be causing these issues :) - Good to know on the DNS. I changed the static to DHCP, I'm hesitant to remove the gateway from the second LAN because I believe that is the port Teamviewer is primarily using (based on upload/download size). I'm going to disconnect one of the ports, if it's a packet feedback issue that should solve it. – ubawesomtu Aug 19 '15 at 16:21
  • Unplugging one of the network cables fixed it, so it must have been a packet feedback error! Thank you for your help, I don't have enough rep to vote your answer up but I really appreciate it. Marking this question as solved. – ubawesomtu Aug 19 '15 at 16:42
  • A gateway is defined as a portal to a different network than your own (19.2.168.8.x). If you know for a fact that any traffic on the LAN-connection is on the same network, a gateway is not required. Removing the Gateway from LAN-connection would force all traffic for the web over the WAN-connection, including Teamviewer. If it fails, it's pretty easy to put back? :) – Anakin Aug 20 '15 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.