this question has been asked multiple times like 1 and 2, but their solutions won't work anymore. Probably because of Plasma 5 and the new firefox versions.

So I am using Kubuntu 15.04, Firefox 40.0 and KDE Plasma Desktop. My default file manager is dolphin. Except Firefox opens another file manager - probably some gnome file manager, because it has no info menu to see its name. But ps -ef suggests, it is nautilus.

What I tried so far

  1. In /usr/share/applications/mimeinfo.cache, change to inode/directory=kde4-dolphin.desktop;(..)
  2. In /usr/share/applications/defaults.list, change to inode/directory=kde4/dolphin.desktop (why use a slash here? See this answer).
  3. installing package kmozillahelper - but this is no longer available.
  4. checking xdg-open by verifying that xdg-open $PWD opens dolphin. This works, but not for firefox.
  5. removing rm ~/.mozilla/firefox/<profile>/mimeTypes.rdf did not work either, as suggested here.
  6. Verified, that there is probably no user setting overriding dolphin with nautilus:

    [~] $ grep -R nautilus .local/share/mime [~] $

So, I'm sorry to re-ask this question, but things have changed. How do I let firefox open folders (download locations) in dolphin?

  • Just compíled kmozillahelper, but I still cannot find the "filepicker" variable. Also, I consider it too complicated for average users who don't want too compile anything. Aug 18, 2015 at 20:19
  • Same issue with nemo - I end up symlinking baking the nautilus excutable and symlinking a new one from the nemo one as suggested here - probably not recommended for varying reasons, and dolphin is different enough that a wrapper script may be better. Apart from that, removing all trace of nautilus.desktop from the mimelists/caches or removing nautilus altogether may work.
    – Wilf
    Aug 18, 2015 at 20:35
  • I cecked and saw that in fact nautilus is a link to dolphin (inside ~/.local/...). So I really don't know what else to do. Aug 24, 2015 at 7:29

1 Answer 1


I had the exact same problem, although I tried different things on the web, this was what helped me in the end.

ln -s /usr/share/applications/kde4/dolphin.desktop ~/.local/share/applications/nautilus-folder-handler.desktop

I found the solution thanks to this bug report in audacious. https://bugs.launchpad.net/ubuntu/+source/audacious/+bug/1196339

As I said, I did try other things before, so maybe it was a combo of the things I did, but I think linking the dolphin.desktop file to the (default) application which should be nautilus-folder-handler.desktop should do the trick.

Hope it helps.

EDIT: After going through all the steps again, I think you also need the following.

$ pwd

$ cat kde-dolphin.desktop 
[Desktop Entry]

$ cat default.list 
[Default Applications]
  • this is a better method from this same user. thanks. askubuntu.com/a/401477/138912 Oct 19, 2018 at 18:48
  • creating the .desktop files and defaults.list inside ~/.local/share/applications worked perfectly for Chromium Jan 6, 2021 at 7:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .