3

Updated my mysql to 5.6 and as a consequence broke my preexisting mysql workbench.

Trying to reinstall the newest mysql workbench, from both the Software Manager and the latest .deb from their downloads page:

Dependency is not satisfiable: libglibmm-2.4-1c2a (>= 2.42.0)

I'm running 14.04, and I've found the package here:

http://packages.ubuntu.com/trusty/libglibmm-2.4-1c2a

How come I can't install mysql workbench? This dependency seems to be in 14.04.

  • Voting to close as unlear because we do not know how MySQL 5.6 was installed, and this is essential to answer the question. (And since the question is over a year old, it is unlikely that OP wil clarify.) – fkraiem Oct 20 '16 at 4:32
  • Honestly I wish I could say. It was so long ago. – Dylan Pierce Jul 16 at 1:42
1

Depending on where you got the package you are currently trying to install, you may have the wrong one - your package needs version (>= 2.42.0) (i.e. newer than 2.42), but the available trusty version is currently 2.39.93.
You may have accidentally got a package for Utopic or newer (possibly via a installed PPA), as both Utopic and Vivid have version 2.42.0-1 available.

However, this package from here seems to only need:

libatkmm-1.6-1 (>= 2.22.1), libc6 (>= 2.14), libcairo2 (>= 1.13.0~20140204), libcairomm-1.0-1 (>= 1.6.4), libctemplate2, libcurl3 (>= 7.16.2), libexpat1 (>= 2.0.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libgl1-mesa-glx | libgl1, libglib2.0-0 (>= 2.35.9),
libglibmm-2.4-1c2a (>= 2.36.2), libgnome-keyring0 (>= 2.22.2), libgtk2.0-0 (>= 2.24.0), libgtkmm-2.4-1c2a (>= 1:2.24.0), libncurses5 (>= 5.5-5~), libpango-1.0-0 (>= 1.18.0), libpangocairo-1.0-0 (>= 1.14.0), libpangomm-1.4-1 (>= 2.27.1), libpcre3, libpcrecpp0 (>= 7.7), libpng12-0 (>= 1.2.13-4), libpython2.7 (>= 2.7), libsigc++-2.0-0c2a (>= 2.0.2), libsqlite3-0 (>= 3.6.0), libstdc++6 (>= 4.6), libtinyxml2.6.2, libuuid1 (>= 2.16), libx11-6, libxml2 (>= 2.7.4), libzip2 (>= 0.10), zlib1g (>= 1:1.2.0), python-paramiko

Which should be available in 14.04 - the offical repo version from here as well also only needs libglibmm-2.4-1c2a (>= 2.36.2).

  • Thanks for helping. I've upgraded my mysql-client to the mysql-client-5.6 so I can no longer sudo apt-get install mysql-workbench because mysql-client-5.6 is not a valid dependency. – Dylan Pierce Aug 19 '15 at 12:41
0

Try to solve this with detecting dependencies:

sudo apt-get -f install 

Then update and install new packages

sudo apt-get update && sudo apt-get upgrade

It solved my problem with the same description.

Cheers :)

  • No reason for -f install if you can install new packages with update && upgrade. It should be ran first. – DnrDevil Mar 9 '16 at 0:03
  • Hm, first I did update & upgrade, and then it offered me to install missing dependincies. But if -f install works first then ok. – vooxo Mar 10 '16 at 12:00
0

remove python-connector-mysql mysql-utilities install mysql-utilites

their is a conflict preventing the proper upgrade path : python-connector-mysql -> mysql-connector-python

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.