3

I'm trying to install Ubuntu as a second OS, but I'm stuck at the turn off secure boot step.

I've found out that to disable secure boot I need to switch from Legacy mode to UEFI mode. But I can't start Windows when UEFI mode is turned on. That means I need to go back to Legacy mode which doesn't have an option to turn off secure boot. I'm confused.

How should I proceed?

  • 1
    Welcome to Ask Ubuntu! :-) Just to be absolutely sure, could you edit your question and add the output to sudo parted --list in "try Ubuntu" mode in a terminal??? (Press [Ctrl][Alt][T] to open a terminal) – Fabby Aug 18 '15 at 19:34
6

Don't do anything: apparently your Windows isn't installed in UEFI mode.

(This is the first time on this site I've told someone to not do anything!)

:-)

  • Sounds great :) But how do I turn off secure boot then? – Nadiya Aug 18 '15 at 19:54
  • In the BIOS... :/ – Fabby Aug 18 '15 at 19:56
  • The option to turn off a secure boot is available only when I switch to UEFI mode – Nadiya Aug 18 '15 at 19:58
  • Then it is turned off automatically... have you tried just skipping that step? – Fabby Aug 18 '15 at 20:26
  • 1
    Like this. If you would get stuck somewhere there, just ask a new question, and specify where exactly things go wrong... ;-) – Fabby Aug 19 '15 at 19:32
5

To elaborate a bit on Fabby's answer:

Modern EFI/UEFI-based computers can usually boot either in native EFI/UEFI mode or using a feature called the Compatibility Support Module (CSM), which enables them to boot using older BIOS-mode boot loaders. This latter mode is often called "legacy mode," so it has three names: BIOS, CSM, and legacy; all mean the same thing in this context, and are distinct from native EFI/UEFI-mode booting.

Secure Boot is a UEFI feature that is active only in UEFI-mode booting. Thus, when you activate BIOS/CSM/legacy support, Secure Boot is either automatically deactivated or becomes relevant only for UEFI-mode boots, depending on the design of the firmware.

If your computer is booting in BIOS/CSM/legacy mode and refuses to boot when you switch the firmware to EFI/UEFI mode, then that implies that Secure Boot is already disabled, or at least bypassed, for booting Windows. Fabby asked for the output of parted -l, and that output will indicate Windows' boot mode with certainty. Specifically, Windows boots in BIOS/CSM/legacy mode only from MBR-partitioned (aka "MSDOS") disks, whereas it boots in EFI/UEFI mode only from GPT-partitioned disks. Thus, the disk type will indicate, with 100% certainty, what the current Windows boot mode is.

As a side note, any instructions that tell you to disable Secure Boot as a matter of course are suspect. Ubuntu has long supported Secure Boot, and should install just fine (in EFI/UEFI mode, of course) on most computers with Secure Boot active. Note the word "most," however; there are a few computers on which Ubuntu's Secure Boot support does not work. IMHO, those are best dealt with on a case-by-case basis rather than issuing instructions to disable Secure Boot on all computers.

  • As usual: much better then my answer... I just couldn't resist answering "don't do anything!"... – Fabby Aug 19 '15 at 10:58
  • So how do I install Ubuntu alongside Windows with legacy mode? – Nadiya Aug 19 '15 at 13:12
  • great answer bro, but I'm a little confused. My disk type is GPT which means my BIOS is on UEFI mode and I'm running dual-boot Ubuntu along with Windows 10, each time I power on my laptop I see the notification that says Secure mode is off. I thought that once is on UEFI mode, secure mode have to be in on state. – Son Nheo Oct 20 '15 at 18:54
  • Secure Boot is an optional feature of UEFI. In fact, it's possible to disable Secure Boot on most UEFI-based computers that support it. – Rod Smith Oct 21 '15 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.