I know there are too many booting problem posts in geek forums, but none of them could help me so i decided to ask here.

I have been using my iMac with Ubuntu 10.04 for almost 1 year. It was perfect and i had no problem, until i decided to make a triple-boot with windows7.

I have repartitioned my drive and and tried to install windows7. It failed. But it also damaged my system. Now i am not able to boot ubuntu. For 3 days i have been trying all the things that are written on the forums, but i really couldn't solve the problem.

First, i got a frozen tux logo when i try to boot ubuntu from refit. Then i boot with gparted and deleted the ntfs partition, reformatted it to ext3 and merging it to my ubuntu partition (sda4) i hoped getting everything same as 3 days before could solve the problem. But it couldn't. now i have a gray windows like icon on refit instead of tux logo and it says boot legacy os from hd. if i try to boot it, it frozen like tux logo, but when i try to boot from apple boot thing (with holding option key) it says "missing operating system, no bootable device blabla"

I have tried synchronize the tables, didnt work. I have also tried restoring mbr and reinstalling grub with boot-repair-disk with every combo of options, (reinstalled grub on sda and sda4, tried to restore mbr on efi, mac and linux parts) they really don't work.

I also boot with live ubuntu cd, and tried to setup grub from terminal. but i failed again.

Please show me another way to fix this. or at least tell me what is the reason that i can't boot ubuntu. (i can boot macos)

I have backed up my personal files with live cd, i will just reinstall ubuntu if i can't fix this, but i'm afraid of ending up with the same result.

Sorry for the long post, i thought giving the details can help you guys determine the problem. thanks.

  • As this question is old can you add some updated information ie:have you re-installed ubuntu and solved your problem? – Mark Rooney Feb 28 '12 at 0:40
  • added an update :-) – jeffisabelle Feb 28 '12 at 7:14
  • Can you convert your update to an answer and accept it as a solution, as part of the site clean up we are trying to get as many unanswered questions solved. – Mark Rooney Feb 28 '12 at 10:49

I did use boot-repair-disk and it helped alot. If you have any booting problem you can check it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.