0

I have a Primus laptop, and I cannot use VDPAU on Nvidia. I have installed Nvidia's proprietary driver from "Additional Drivers", but if I run "vainfo" in a terminal I get the error message:

imran@imran-PC:/usr/lib/x86_64-linux-gnu/dri$ vainfo
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva error: /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

If I run this on Intel HD Graphics then the output is fine. I cannot play 4K videos in VLC media player or MPlayer using VDPAU.

Any suggestions?

  • What is Ubuntu version? Which drover did you install? Please add output of prime-select query terminal command. – Pilot6 Aug 17 '15 at 19:25
  • @Pilot6, Output of "prime-select query" is "nvidia". I am using Ubuntu 15.04 with NVIDIA Proprietary driver version 340.76 from nvidia-340. – Linux Holic Aug 18 '15 at 9:20
0

You need to upgrade the driver

sudo apt-get purge nvidia*
sudo killall nvidia-persistenced
sudo apt-get install nvidia-346 nvidia-prime

Reboot.

  • Already installed :) – Linux Holic Aug 18 '15 at 11:22
  • Updated the answer. 340 seems to be too old for 840M. @user294573 – Pilot6 Aug 18 '15 at 11:32
  • Ok, so i did installed nvidia-346 but still i am getting error if i type "vainfo" in terminal. – Linux Holic Aug 18 '15 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.