2

Whan I ran;:

ifconfig

eth0      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxxxx 
          inet addr:192.168.1.7  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: xxxxxxxxxxxxxxxxxxxxxx Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:48983 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30735 errors:0 dropped:47 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:64920261 (64.9 MB)  TX bytes:2492770 (2.4 MB)
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1858 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1858 errors:0 dropped:0 overruns:0 carrier:0`
          collisions:0 txqueuelen:0 
          RX bytes:316774 (316.7 KB)  TX bytes:316774 (316.7 KB)

$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.


$ lspci | grep Network
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)

$rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

sudo lspci

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
03:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

Update

/etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
/etc/modprobe.d/blacklist-ath_pci.conf
# For some Atheros 5K RF MACs, the madwifi driver loads buts fails to
# correctly initialize the hardware, leaving it in a state from
# which ath5k cannot recover. To prevent this condition, stop
# madwifi from loading by default. Use Jockey to select one driver
# or the other. (Ubuntu: #315056, #323830)
blacklist ath_pci

    /etc/modprobe.d/blacklist.conf
    # This file lists those modules which we don't want to be loaded by
    # alias expansion, usually so some other driver will be loaded for the
    # device instead.

    # evbug is a debug tool that should be loaded explicitly
    blacklist evbug

    # these drivers are very simple, the HID drivers are usually preferred
    blacklist usbmouse
    blacklist usbkbd

    # replaced by e100
    blacklist eepro100

    # replaced by tulip
    blacklist de4x5

    # causes no end of confusion by creating unexpected network interfaces
    blacklist eth1394

    # snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
    # hardware on its own (Ubuntu bug #2011, #6810)
    blacklist snd_intel8x0m

    # Conflicts with dvb driver (which is better for handling this device)
    blacklist snd_aw2

    # causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
    blacklist i2c_i801

    # replaced by p54pci
    blacklist prism54

    # replaced by b43 and ssb.
    blacklist bcm43xx

    # most apps now use garmin usb driver directly (Ubuntu: #114565)
    blacklist garmin_gps

    # replaced by asus-laptop (Ubuntu: #184721)
    blacklist asus_acpi

    # low-quality, just noise when being used for sound playback, causes
    # hangs at desktop session start (Ubuntu: #246969)
    blacklist snd_pcsp

    # ugly and loud noise, getting on everyone's nerves; this should be done by a
    # nice pulseaudio bing (Ubuntu: #77010)
    blacklist pcspkr

    # EDAC driver for amd76x clashes with the agp driver preventing the aperture
    # from being initialised (Ubuntu: #297750). Blacklist so that the driver
    # continues to build and is installable for the few cases where its
    # really needed.
    blacklist amd76x_edac
    /etc/modprobe.d/blacklist-firewire.conf
    # Select the legacy firewire stack over the new CONFIG_FIREWIRE one.

    blacklist ohci1394
    blacklist sbp2
    blacklist dv1394
    blacklist raw1394
    blacklist video1394

    #blacklist firewire-ohci
    #blacklist firewire-sbp2
    /etc/modprobe.d/blacklist-framebuffer.conf
    # Framebuffer drivers are generally buggy and poorly-supported, and cause
    # suspend failures, kernel panics and general mayhem.  For this reason we
    # never load them automatically.
    blacklist aty128fb
    blacklist atyfb
    blacklist radeonfb
    blacklist cirrusfb
    blacklist cyber2000fb
    blacklist cyblafb
    blacklist gx1fb
    blacklist hgafb
    blacklist i810fb
    blacklist intelfb
    blacklist kyrofb
    blacklist lxfb
    blacklist matroxfb_base
    blacklist neofb
    blacklist nvidiafb
    blacklist pm2fb
    blacklist rivafb
    blacklist s1d13xxxfb
    blacklist savagefb
    blacklist sisfb
    blacklist sstfb
    blacklist tdfxfb
    blacklist tridentfb
    #blacklist vesafb
    blacklist vfb
    blacklist viafb
    blacklist vt8623fb
    blacklist udlfb
    /etc/modprobe.d/blacklist-libnfc.conf
    blacklist nfc
    blacklist pn533
    /etc/modprobe.d/blacklist-modem.conf
    # Uncomment these entries in order to blacklist unwanted modem drivers
    # blacklist snd-atiixp-modem
    # blacklist snd-intel8x0m
    # blacklist snd-via82xx-modem
    /etc/modprobe.d/blacklist-oss.conf
    blacklist ac97
    blacklist ac97_codec
    blacklist ac97_plugin_ad1980
    blacklist ad1848
    blacklist ad1889
    blacklist adlib_card
    blacklist aedsp16
    blacklist ali5455
    blacklist btaudio
    blacklist cmpci
    blacklist cs4232
    blacklist cs4281
    blacklist cs461x
    blacklist cs46xx
    blacklist emu10k1
    blacklist es1370
    blacklist es1371
    blacklist esssolo1
    blacklist forte
    blacklist gus
    blacklist i810_audio
    blacklist kahlua
    blacklist mad16
    blacklist maestro
    blacklist maestro3
    blacklist maui
    blacklist mpu401
    blacklist nm256_audio
    blacklist opl3
    blacklist opl3sa
    blacklist opl3sa2
    blacklist pas2
    blacklist pss
    blacklist rme96xx
    blacklist sb
    blacklist sb_lib
    blacklist sgalaxy
    blacklist sonicvibes
    blacklist sound
    blacklist sscape
    blacklist trident
    blacklist trix
    blacklist uart401
    blacklist uart6850
    blacklist via82cxxx_audio
    blacklist v_midi
    blacklist wavefront
    blacklist ymfpci
    blacklist ac97_plugin_wm97xx
    blacklist ad1816
    blacklist audio
    blacklist awe_wave
    blacklist dmasound_core
    blacklist dmasound_pmac
    blacklist harmony
    blacklist sequencer
    blacklist soundcard
    blacklist usb-midi
    /etc/modprobe.d/blacklist-rare-network.conf
    # Many less commonly used network protocols have recently had various
    # security flaws discovered. In an effort to reduce the scope of future
    # vulnerability exploitations, they are being blacklisted here so that
    # unprivileged users cannot use them by default. System owners can still
    # either modify this file, or specifically modprobe any needed protocols.

    # ax25
    alias net-pf-3 off
    # netrom
    alias net-pf-6 off
    # x25
    alias net-pf-9 off
    # rose
    alias net-pf-11 off
    # decnet
    alias net-pf-12 off
    # econet
    alias net-pf-19 off
    # rds
    alias net-pf-21 off
    # af_802154
    alias net-pf-36 off
    /etc/modprobe.d/blacklist-watchdog.conf
    # Watchdog drivers should not be loaded automatically, but only if a
    # watchdog daemon is installed.
    blacklist acquirewdt
    blacklist advantechwdt
    blacklist alim1535_wdt
    blacklist alim7101_wdt
    blacklist booke_wdt
    blacklist cpu5wdt
    blacklist eurotechwdt
    blacklist i6300esb
    blacklist i8xx_tco
    blacklist ib700wdt
    blacklist ibmasr
    blacklist indydog
    blacklist iTCO_wdt
    blacklist it8712f_wdt
    blacklist it87_wdt
    blacklist ixp2000_wdt
    blacklist ixp4xx_wdt
    blacklist machzwd
    blacklist mixcomwd
    blacklist mpc8xx_wdt
    blacklist mpcore_wdt
    blacklist mv64x60_wdt
    blacklist pc87413_wdt
    blacklist pcwd
    blacklist pcwd_pci
    blacklist pcwd_usb
    blacklist s3c2410_wdt
    blacklist sa1100_wdt
    blacklist sbc60xxwdt
    blacklist sbc7240_wdt
    blacklist sb8360
    blacklist sc1200wdt
    blacklist sc520_wdt
    blacklist sch311_wdt
    blacklist scx200_wdt
    blacklist shwdt
    blacklist smsc37b787_wdt
    blacklist softdog
    blacklist twl4030_wdt
    blacklist w83627hf_wdt
    blacklist w83697hf_wdt
    blacklist w83697ug_wdt
    blacklist w83877f_wdt
    blacklist w83977f_wdt
    blacklist wafer5823wdt
    blacklist wdt
    blacklist wdt_pci
    blacklist wm8350_wdt
    /etc/modprobe.d/fbdev-blacklist.conf
    # This file blacklists most old-style PCI framebuffer drivers.

    blacklist arkfb
    blacklist aty128fb
    blacklist atyfb
    blacklist radeonfb
    blacklist cirrusfb
    blacklist cyber2000fb
    blacklist gx1fb
    blacklist gxfb
    blacklist kyrofb
    blacklist matroxfb_base
    blacklist mb862xxfb
    blacklist neofb
    blacklist nvidiafb
    blacklist pm2fb
    blacklist pm3fb
    blacklist s3fb
    blacklist savagefb
    blacklist sisfb
    blacklist tdfxfb
    blacklist tridentfb
    blacklist viafb
    blacklist vt8623fb
    /etc/modprobe.d/iwlwifi.conf
    # /etc/modprobe.d/iwlwifi.conf
    # iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
    # microcode file installed on the system.  When removing iwlwifi, first
    # remove the iwl?vm module and then iwlwifi.
    remove iwlwifi \
    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
    && /sbin/modprobe -r mac80211
    /etc/modprobe.d/mlx4.conf
    # mlx4_core gets automatically loaded, load mlx4_en also (LP: #1115710)
    softdep mlx4_core post: mlx4_en
    /etc/modprobe.d/modesetting.conf
    options cirrus modeset=1
    options mgag200 modeset=1
    /etc/modprobe.d/rt73.conf
    # RT73 driver

    # Uncomment these entries to not load other drivers for the same device
    # blacklist prism2_usb
    # blacklist rt2500usb
    # blacklist rt2570
    # blacklist rt73usb

    # Alias for rausb0 interface
    # alias wlan0 rt73
    /etc/modprobe.d/vmwgfx-fbdev.conf
options vmwgfx enable_fbdev=1


$ lspci -knn | grep Net -A2
02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 73)
    Subsystem: Intel Corporation Wireless-N 7260 [8086:4462]
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5287] (rev 01)

M kernel version is 3.16.0-45-generic

I need help please :( I have tried everything!

15
  • Edit your question and add the output of lspci | grep Network Aug 17, 2015 at 19:28
  • I did updated it. @daltonfury42
    – Mr Day2Day
    Aug 17, 2015 at 19:47
  • Which version of Ubuntu are you running? Have you tried updating? (sudo apt-get dist-upgrade) Aug 17, 2015 at 19:54
  • @daltonfury42 Ubuntu 14.04.3 LTS
    – Mr Day2Day
    Aug 17, 2015 at 19:57
  • i would like to think so..... is there is way i can check and make sure.
    – Mr Day2Day
    Aug 17, 2015 at 19:59

2 Answers 2

0

In command ifconfig it will show wlan0 when your wifi is enabled. so , you have to enable it from network-manager.

check your wireless card is not blocked using command

rfkill list

if blocking then make them unblocked using command

sudo  rfkill unblock wifi
5
  • rfkill list 0: hci0: Bluetooth Soft blocked: no Hard blocked: no
    – Mr Day2Day
    Aug 17, 2015 at 19:48
  • is there any output related to wireless ?
    – pl_rock
    Aug 17, 2015 at 19:50
  • There is none. :(
    – Mr Day2Day
    Aug 17, 2015 at 19:50
  • may be wireless driver not installed ? check sudo lshw -C network | grep driver . output should be like ` broadcast=yes driver=iwlwifi driverversion=3.13.0-24-gene` if not installed then try sudo apt-get install firmware-b43-installer
    – pl_rock
    Aug 17, 2015 at 20:05
  • this did not work :(
    – Mr Day2Day
    Aug 17, 2015 at 21:16
0

As for the wireless, I suggest you try the newer firmware file. First, back up the existing file:

cd /lib/firmware
sudo mv iwlwifi-7260-7.ucode  iwlwifi-7260-7.ucode.bak

Now download the newer file:

sudo wget https://git.kernel.org/cgit/linux/kernel/git/egrumbach/linux-firmware.git/plain/iwlwifi-7260-7.ucode

Reboot and tell us if it works better now.

2
  • mv: cannot stat ‘iwlwifi-7260-7.ucode’: No such file or directory so I am going to do the next best thing and go ahead and install the driver
    – Mr Day2Day
    Aug 17, 2015 at 20:24
  • #sigh Still nothing.... I honestly do not know what is going on.
    – Mr Day2Day
    Aug 17, 2015 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.