2

I'm a newbie to linux. I'm still trying to figure things out. I ditched Windows 8.1 after their free upgrade to Windows 10.

I used gparted live to delete the partitions of the disk (500gb hitachi HDD) then partitioned and formatted the hdd to a ext4 format. I burned the KUbuntu 15.04 iso to a DVD and booted to perform a new install. I used the non-UEFI CD drive.

During the installation of Kubuntu the installer asked me about the size of the partition. I accepted the installations default which was two partitions each at approx 230 GB.

I thought it would be like in Windows where you could see two disk drives and be able to save to either one. Once I got into the new OS I can see both drives listed. When I click on the second partition I see a folder in their but cannot open the folder. I cannot add a new folder to the drive to save anything onto it. The second partition seems to have no purpose. I used gparted to see the partitions and it lists the second partition as an extended partition. It shows approx 10 gb used on that partition.

Now that I have everything setup the way I like it (took several hours) I would rather not start over to get the partition size right. Is there a way to either use the second partition so I can save files to it or a way to combine both partitions together without losing anything? Of course I would back up before I would do anything just in case.

lsblk command in terminal:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0 235.4G  0 part /media/sesslercory/0562fcf0-4d4e-4
├─sda5   8:5    0 226.7G  0 part /
└─sda6   8:6    0   3.7G  0 part [SWAP]
sr0     11:0    1  1024M  0 rom 

sudo parted -l:

Model: ATA Hitachi HTS54505 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B                         
Partition Table: msdos                                             
Disk Flags:                                                        

Number  Start   End    Size    Type      File system     Flags     
 1      1049kB  253GB  253GB   primary   ext4            boot      
 2      253GB   500GB  247GB   extended                            
 5      253GB   496GB  243GB   logical   ext4                      
 6      496GB   500GB  3963MB  logical   linux-swap(v1) 

ls -l:

    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 19:16 Desktop
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 01:11 Documents
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 16 12:06 Downloads
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 01:11 Music
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 01:11 Pictures
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 01:11 Public
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 01:11 Templates
    drwxr-xr-x 2 sesslercory sesslercory 4096 Aug 13 01:11 Videos
  • Please edit your question and add the output of lsblk. Are you sure that the second partition is not used? I think your second partition is mounted in /home folder. So everything outside /home is your first partition and whatever is inside /home is your second partition. It could be pretty confusing to windows users, but I suggest reading more about it on the net. – daltonfury42 Aug 17 '15 at 15:50
  • If OP cannot write to partition, I am guessing it is swap which normally in a BIOS install is a logical partition ( often sda5) inside an extended partition. Post this also sudo parted -l and ls -l – oldfred Aug 17 '15 at 16:01
  • My guess is, when you installed Kubuntu, it saw the ext4 partition you had created and assumed that partition has another OS in it, and offered to shrink that partition to make room for Kubuntu. Since there is no OS or data in it, you can use a Live DVD/USB (Try Kubuntu without installing option) and delete the initial partition and expand the one with Kubuntu. Please edit your question and paste the output of lsblk as others have suggested. – user68186 Aug 17 '15 at 16:24
  • Thank you for all of your comments. @daltonfury42 where should I add the "lsblk" I tried to in the tags but the forum would not allow me. When you say output what does that mean ... Sorry if that's a dumb question. Also you make an interesting point about whether the partition is mounted in the home folder. I can test that by adding a sizable file to the home folder to see if that increases the usage in the partition size. I'll keep you posted. – Cory Sessler Aug 17 '15 at 18:06
  • @ user68186, thank you for your suggestion. It also makes good sense. I will see if I can edit partitions by using the live dvd. Hopefully I don't delete the wrong partition lol. I'll keep you posted on my findings. Also I am trying to figure out what you mean by "output" in this thread. Do you mean tags? For some reason the forum will not allow me to add the tag lsblk. – Cory Sessler Aug 17 '15 at 18:10
1

Open the other partition in the file browser and press ctrl+L. You will be shown a path. Copy it. Then open a terminal and enter

cd "[whatever path]"

Where [whatever path] is the path you copied. Keep the quotes. They don't do any harm and make things easier if there are spaces or some other characters in the path. This will set your location in the current terminal to the mount point of your second partition.

Then enter these commands:

sudo chown -R [your user name] .
sudo chmod -R 777 .
sudo chown -R root "lost+found"
sudo chmod -R 700 "lost+found"

This will set the rights the way you want them to be. The first command makes you the owner of everything on the partition. The second command gives you all rights to it, but also every other user of the computer, in case you want to have several accounts and share files this way. If you don't want to do so, change 777 to 700 (others can't do anything) or to 722 (others can only read). The last 2 commands set everything back to the previous state for the (hidden) folder "lost+found" which is a special folder which you probably never will not have to use.

  • YES that worked! Wow that's crazy ... Thank you so much :) Amazing! Now I can create folders and use the space. This really makes me wonder why I didn't switch to linux years ago! What support :) – Cory Sessler Aug 18 '15 at 5:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.