0

I added .sh file to /etc/profile.d. Now my laptop just gets stuck at login prompt - showing it over and over again. Is there any way to access and remove this script? Ubuntu Live treats my filesystem as read-only

  • Login from the TTY (Ctrl-Alt-F2)? – muru Aug 17 '15 at 11:33
  • The same thing. I also tried Ubuntu recovery mode's CLI but it treats FS as read-only – Etienne Kahn Aug 17 '15 at 11:37
  • In recovery mode, did you mount it as rw? mount -rw -o remount /? – muru Aug 17 '15 at 11:38
  • Oh, I didn't mount anything manually. Just answered the prompts. So should I mount it by myself? – Etienne Kahn Aug 17 '15 at 11:40
  • Yes, of course. – muru Aug 17 '15 at 11:41
2

In recovery mode, unless you use the root shell with networking option, you need to manually mount / for writing:

mount -rw -o remount /
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.