0

I have a computer in my living room that I built myself to use as an ssh server to run various programs on as a fun project. I put Ubuntu Server 14.04 on there, and then used Google to figure out how to set it up to let me ssh into it to program and do other things on it. This worked perfectly for a while. I was able to ssh in on my Mac from anywhere, and I was able to have multiple terminals all ssh-ed in at once. I could also reboot remotely, wait a minute, and then get right back in.

Then AT&T came and replaced our router. Ever since then, I haven't been able to consistently ssh into the machine. If I can't get in, I can physically power off the machine and then physically turn it back on again, and then I can usually ssh into it no problem; only that one time though. After that, I will either get a "Connection Refused" error or more often an "Operation Timed Out" error. I also am never able to get more than one terminal logged into the machine. I am assuming that this is because of something that happened when the router got switched but I can't figure it out.

I did have to add my port forwarding rules on the new router and I did that by memory, so maybe something went wrong there? Any help is greatly appreciated. I'm pretty new at this if you can't tell...

*8/21 edit

I reinstalled Ubuntu Server 14.04 on my machine and reconfigured ssh. I am having more luck being able to ssh into it now, but I am still having an issue where once I log in once, it won't let me log in again from a different terminal. I don't have it set to only allow one log in, so I don't know what the issue is.

1 Answer 1

0

It could have something to do with your server switching internal ip address. Try setting your server to a fixed address.

1
  • It always stays at a fixed address. I always connect using the same ip address, its just that sometimes it will connect and other times (usually after I logout) it will tell me the connection timed out or something like that.
    – SoaringFox
    Aug 20, 2015 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.