0

I have been using "Additional Drivers" to switch back and forth between the open source and binary drivers for my AMD video card (R9 270X)

The open source driver is my only choice for gaming, because it performs with immensely vastly ridiculously lower latency. Gaming on fglrx is literally physically disgusting, but I need to switch back to fglrx occasionally for software development.

The other day, I did my routine switch back to the open source driver, but it utterly screwed my configuration somehow and now neither driver works. I've tried almost every single thing found online, here, google, anywhere. I've literally even tried silly suggestions that are barely related, just on the off chance it maybe uncovers something. I've tried EVERY solution you will find on Ask Ubuntu.

enter image description here

I had never manually installed a driver! It even said it successfully switched back to the open source one before I rebooted!!

AFTER all of this, after trying to work it out the "Ubuntu Way", I decided to actually try manually installing a driver, since the software seems so keen on that anyways lol. I got fglrx from AMD's website, of course this resulted in further mutilation of my configuration; After about 2 days I've managed to fix that and get back to being able to boot, at least. I am still stuck with no acceleration and my usual disgust for GUI configuration.

I have been using Linux for many years, have always been a Debian fan, and am comfortable working in command line. I have been trying (and hating these exact type of problems that feel like a half-ass python GUI is to blame) since the very beginning of Ubuntu almost a decade ago. I'm doing all I can to not denounce it as rubbish after every seeing every single install (mine, friends, coworkers) eventually fall apart in some magical way like this. Please help.


EDIT: After deleting lock files, the only difference I observe is the "package" icon being replaced by a "green light" icon:

enter image description here

-1

Please Remove all lock files by running this in Terminal:


sudo rm /var/lib/dpkg/lock
sudo rm /var/lib/apt/lists/lock

You will need to be connected to the internet.

  • Sadly, it does not achieve the desired effect, but it does make a small change in the program state. The "package" icon is replaced by a "green light" icon, I will attach a picture to the original post. – MickLH Aug 16 '15 at 18:54
  • do you remove all lock files? like: /var/lib/dpkg/lock – Md Kamruzzaman Aug 17 '15 at 15:01
  • Where do you see a lock problem? – A.B. Aug 17 '15 at 18:52
  • I tried all permutations of deleting lock files, rebooting, and starting the additional drivers tool, that "green light" icon was the only thing I could consistently achieve (by deleting the lock files and then immediately restarting the program) – MickLH Aug 17 '15 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.