The "acpi pcc probe failed" problem when booting Ubuntu 15.04 is still causing me problem. I have tried with "nomodeset" but with the same result. As I'm not able to launch the shell I don't know how to resolve this unless reinstalling with data getting lost as a consequence. Have even tried with the "boot-repair" without getting 15.04 up and running. http://paste.ubuntu.com/12096378/ Anyone out there that has resolved my problem?



  • 1
    Welcome to Ask Ubuntu! ;-) ACPI PCC Probe failed is just a warning. Could you please go to a terminal by pressing [Ctrl][Alt][T] and type dmesg | grep error. Then edit your question and copy-paste the output of the command into your question so we can see what's really going on... Then leave a comment @Fabby.
    – Fabby
    Aug 16, 2015 at 17:51

2 Answers 2


By doing this, you will no longer see the "ACPI PCC Probe failed" warning message at boot. But, your Ubuntu will disable the "Suspend" power feature and other onboard function keys for laptop, such as "Brightness", "Volume", and other shortcuts as well.

Let's start edit GRUB:

sudo nano /etc/default/grub

Find this line:


Add "acpi=off", and it will looks like this:


Save and update GRUB:

sudo update-grub

You can now reboot.


Since the message comes from the pcc_init function, which is part of a built-in module in the kernel, you can modify /etc/default/grub as follows:


you will see the following in the syslog:

initcall pcc_init blacklisted

I found this to be a more pinpoint fix. Using "acpi=off" caused more boot issues than it fixed. BTW the pcc_init function is located in /drivers/mailbox/pcc.c in the kernel sources >= 3.19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.