I am using Lenovo Thinkpad laptop with ATI Radeon HD 3400 Series graphic card. I installed Ubuntu 11.10 64 bit today and tried to install proprietary drivers

1)Hence I installed proprietary drivers displayed on my system (through jockey) .Rebooted my system. Performance is better now but Still compiz is not working.

2)Then I tried the second driver available - 'post-release-updates' but couldn't install due to some error. Hence I opened synaptic and installed fglrx-updates and rebooted my system. Not much change and still compiz didnt work

3)Removed all these packages and downloaded the latest driver from ATI http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product= and installed it and rebooted my system. This is worse as I dnt get even launcher or dash this time - I guess I am forcefully logged in to Ubuntu 2-D . Still compiz is not working

Am I doing something silly here ? Is any one facing similar issues with ATI ? Please help Thanks.

  • As a NVidia user, I only had to download the driver from NVidia.com and install it. Compiz and everything else work perfectly. I have avoided the proprietary drivers. It most likely is ATI/11.10 compatibility issues. Hope you get the problem fixed, no thanks to me though :) – Trevor Oct 14 '11 at 14:45
  • Haha good for you. Yeah support for Nvidia is better than that of ATI :) – mac Oct 14 '11 at 14:59
  • Depends on what you want! At least games on wine work nice on ATI, who cares about unity3d anyways! – Bruno Pereira Oct 14 '11 at 15:03

This is a good solid guide to getting the latest ATI driver installed in ubuntu. http://wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29

Has some good troubleshooting tips too.


If your BIOS supports switchable display it should be disabled in favor of discrete graphics adaptor. The drivers cannot handle switchable graphics.


No, you're not alone. I also have problems with the ATI driver under 11.10 64bit.

I'm just guessing but I think this problem has to do with the way support for 32bit applications was added to the 64bit image.

I reverted to 11.04 and the ATI driver from amd.com works fine. I think we'll have to wait until the new release from ATI.

  • Instead of reverting back to 11.04, I am using open source drivers available by default with 11.10 and I have to say its cool enough :) – mac Oct 16 '11 at 14:28
  • I agree, but I think that's only true for HD5xxx and upwards. – Jo-Erlend Schinstad Oct 16 '11 at 14:30

I posted this on a similar question.

To expand on duffydack's answer (which I followed also) I first purged the system of fglrx in recovery, after remounting and dropping into netroot.

  • did it work for you? – mac Nov 2 '11 at 7:51
  • Yes, perfectly. Currently don't have any issues. Though I am using HD57xx card. – kikixx Nov 2 '11 at 10:30

ATI just released the 11.11 drivers Here's the link http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=

  • 1
    Thanks ... Has Any one tried this? I would be very happy to see it working :) – mac Mar 8 '12 at 9:56

Here is a quick and dirty guide to installing proprietary drivers for Nvidia 8400GS video card. Also this tutorial will work for any other type of proprietary driver you need to install. Proprietary Drivers Ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.