0

I'm running Ubuntu 15.04 as a Virtual Machine in VirtualBox on a Windows machine. I have 3D acceleration enabled, as well as all the fancy CPU features. In other words, pretty much my whole CPU and most of my RAM (I've set it all the way to 2GB and the problem persists) are dedicated/exposed to Ubuntu.

The symptoms shown are:

laggy menus/graphics overall
extremely slow operation in Text only interface

I've run a memory check with

free -m

but there's plenty of memory left (>700MB) and no swap in use. The CPU however, is showing about 150% usage (Hmmm, what's that supposed to mean...). Are there some drivers I need for my CPU, or is something else wrong?

I've used this same exact machine with NO HARDWARE CHANGES (also with less RAM, by the way) to run Ubuntu natively, and it performed outstanding. How comes is dis?

Hardware list:

AMD Athlon X2 64 2.2GHz dual core CPU
Nvidia GeForce 6800 GPU
3GB 800MHz DDR2 (2GB exposed)
and several decent hard drives

UPDATE:

Since the time I asked this question, I have tinkered around trying to get it to work some. I installed the VirtualBox Guest Addition Kernel Modules, and now it is stuck in an infinite loop at the GUI login, and is 100% inaccessible. I can't get to the TUI, and nothing works. So, since it looks like I'll be doing a reinstall now, I'm open to answers that require that.

UPDATE:

I've installed more RAM (I now have 6GB) so I can test with adding extra RAM up to 4 or 5GB to the guest OS.

  • Your CPU % is right in some sence try to run the top command and press 1 to show CPU utilization for each processor/core adding all cores and processors up generates a number that maxes out at NumCor x 100%! I know it feels strange with % larger than 100, but the interesting thing is that no core get to score an even 100 at a prolonged time !! – Ken Mollerup Nov 8 '15 at 16:48
0

I have worked hard last 2 mounth to resolve same probleme, AMD Athlon X2 64 3.1GHz dual core CPU, Nvidia GeForce 6800 GPU, 4GB DDR2, I have finaly solve the problem with the driver names Nvidia Legacy ... terminate by .update, i have make some little change in the bios to set the performance to medium performance and the computer work very whell now. No black screan on logon, flashing screan with the default x.org driver is ending.

Have a nice day! Enjoy IT

1

Leaving the graphics issue aside, Ubuntu is, in my opinion, pretty heavy on a VM.

Lubuntu, however, is very light (LXDE in particular); I successfully ran 8 VMs of Lubuntu 15.10 simultaneously (each having 650 MB of RAM and Guest Addition) with minimal lag. You might want to try that.

  • Thanks for the tip! I'm not a big fan of the light installers, but I can definitely swap GUIs! – Daniel Jan 25 '16 at 0:23
0

The answer: Nothing solved this problem. It has magically disappeared on it's own for the most part, although there is an occasional graphics lag in the GUI. I assume installing GPU drivers might help with that, but I'm not sure.

Long story short, if you leave well enough alone for a couple days, it might give up and quit bugging you altogether!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.