0

I have two Optimus laptops, one with 820m and 14.04, one with 980m and 15.10. Under 15.10 glmark2 worked only until the first Ubuntu update, has been crashing ever since, same for the version I hand-compiled. Getting CUDA working on both was a struggle, dualbooting with Windows 8, but at some point worked, with one quirk: the first time I would run a CUDA program, I had to sudo, after that and until I rebooted normal users could run CUDA.

Installing 10 DID NOT break my grub/ubuntu, but one of these updates that Microsoft pushes "involuntarily" did leave me with broken grub prompts on both machines, at least thats my theory, since I did check my Ubuntus after the very initial 10 "upgrade".

I was able to recover my grubs into the dreaded "broken NVIDIA" login, with and without updates, upgrades and various NVIDIA.run packages all tried in vain. Installing nvidia-346-updates on the 820m got me back on track with CUDA 7.0, all OK. On the 980m, if I login as guest I do get some NVIDIA functionality as reported by glxinfo, OpenGL renderer string: GeForce GTX 980M/PCIe/SSE2 OpenGL core profile version string: 4.4.0 NVIDIA 346.82 OpenGL core profile shading language version string: 4.40 NVIDIA via Cg compiler

my usual login flashes the NVIDIA logo for a split second and kicks me out. I can't believe this is the dreaded "remove broken .profile" issue, although I will try, any ideas what it can be?

Thanks!

1

Well, .profile and associated files did not recover my lightdm,but I installed LXDE and CUDA 7.5RC1 with the .deb package and now booting succesfully into the Nvidia drivers, plus CUDA does not have the "sudo" quirk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.