2

Just got my new computer and installed 14.04.03.

No errors during install.

Nvidia video card with prop. drivers (geforce gts 970- version 346 and 352 of drivers tried)

After installing steam-launcher and clicking it to install Steam a terminal window pops up with the following

Steam needs to install these additional packages: 
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

after entering password I get the following"

    Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Press return to continue: 

The only question I could find with the same issue was Dependency problems installing steam the accepted answer was to sudo apt-get -s install libgl1-mesa-glx-lts-utopic:i386 and then run it if the test worked. My test gives me

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-session-bin : Depends: libgl1-mesa-glx or
                              libgl1
 libcheese-gtk23 : Depends: libcheese7 (>= 3.4.0) but it is not going to be installed
                   Depends: libclutter-1.0-0 (>= 1.13.2) but it is not going to be installed
                   Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                   Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libgl1-mesa-glx-lts-utopic:i386 : Depends: libglapi-mesa-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
                                   Depends: libgl1-mesa-dri-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 libgnome-desktop-3-7 : Depends: libgl1-mesa-glx or
                                 libgl1
 libqt5gui5 : Depends: libgl1-mesa-glx or
                       libgl1
 libqt5multimedia5-plugins : Depends: libqgsttools-p1 (>= 5.2.1-0ubuntu5) but it is not going to be installed
 libqt5quick5 : Depends: libgl1-mesa-glx or
                         libgl1
 libwebkitgtk-3.0-0 : Depends: libgl1-mesa-glx or
                               libgl1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I am using the new graphic driver ppa https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa so could the libs from there be causing this?

If not that anyone know how to fix this, the whole reason I upgraded my computer was to get better performance in games so this is a real slap in the face.....


Edit: removing the ppa has no effect. It would seem that the problem is with libgl1-mesa-dri:i386 If you try to install it with apt-get you get errors about unity-control-center that are above. Synaptic will not even find the them and if you try with the Software Center you get a warning:

enter image description here


Update #2 Steam will now launch but will still pop up the terminal window wanting to install the three libs above. If you close the window Steam will launch and appears to be working normally. I was able to restore my games and launched one so far.

Pleas do not consider this resolved. I would like to no be pestered by the window every time I start and I would like to know what might have happened that it's suddenly working, I don't remember installing any libs, only trying to install the ones above manually. If I ever have to do a reinstall I need to know how to fix it, other that repeatedly trying to install, pulling out my hair smashing my head off the desk then repeating......

0

Original answer

I solved the problem using Synaptic and installing steam:i386 not steam-launcher (that Synaptic does not find)


Edit by the question OP to add an explanation and more info

Using the commands in the answer above the Steam install went fine but it has some quirks:

1st some background: I initially installed Steam with the Software Center's "Reinstall previous purchases function. This installed steam-launcher Which as the answer above states cannot be found by Synaptic. This is because Synaptic only finds programs that are already in the repos but Steam launcher is in it own ppa. The Software Center can see "for purchase" applications, which is what Steam initially was released as. "For purchase" here does not necessarily mean that you have to spend money, what this function does is allow you to install apps that are only available in their own ppa. Installing this was add the ppa as well as the program.


For some reason installing in the above manner does not pull in the libs from the vivid stack only the original trusty repos and the trusty-updates repos. This causes the conflicts and the dependency errors that I posted in my question. Installing per this answer corrects this issue and pulls from vivid.

There appear to be several ways to get the steam:i386 one is using Synaptic. The other graphical way is the Software Center but you have to click on the bottom left of the window to "Show [a number of] technical items" In my tests this also brings up the steam:i386 option.

That last way is using the terminal and typing sudo apt-get install steam:i386 (note that here for some reason using the Tab button to auto-complete doesn't work here you have to type the whole steam:i386 out.

Using the terminal to do a simulation I saw that it would install the libs from the vivid repos and that I got no errors. I went ahead and installed.

If you check via Synaptic you will see that it pulls in a newer version of Steam than steam-launcher installs, it also installs slightly differently. These differences lead to the quirks I mentioned above.


The quirks

Steam now installs in .steam where as .steam used to just be a link to where the actual Steam install was. To wit: .local/share/steam This is the cause of the quirks that I will list below.

Steam will not find that apps that are in the old location and will want to re-download them all. If are doing a drag and drop an old folder of the steam apps that you saved previously they need to go in .steam/steam/steamapps/common (note that steamapps is no longer capitalized). The appmanifest files will still go in the steamapps folder but do not copy the libraryfolders.vdf as that info will have changed to a new location. If you did not save the appminifest files, it's little matter; Steam will just think the games are not installed but if you have placed the steamapps file in the proper location, you can just click the "install" button in Steam, Steam will start the install and then discover the existing files and have to validate them. This will still work fine but will take some extra time as you have to do this for each game.


Final thoughts:

If, like me, you have tried to install Steam via the "Reinstall previous purchases" function before installing Steam as detailed above, you should remove the old Steam repos to avoid conflicts. Just open "Software and Updates" from the dash then go to the "other Software" tab, click on the "installed by the software center...steam repo" selection and hit the "Remove" button. When you close the window allow the "Refresh" in the prompt and then you can go about the install.

It would appear the installing this way only install Steam locally, whereas the steam-launcher was installed system-wide. This is really only a question of semantics, as steam-launcher didn't really install anything but a link that would activate an option for all users to install Steam. The .desktop file is installed system wide so other users only need to click the icon to install.

In either case Steam itself only installed to the local users files and had to be reinstalled for each user. There is a way to link to the game files for each user so that they can share the actual games and not have to reinstall the same game numerous times but as I never needed to do that, that is beyond my experience.

It looks like you can get the correct version of steam by just installing steam via apt-get, at least after I used steam:i386 sudo apt-get install steam will tell you that "steam:i386 is already the newest verison" Just using steam will allow auto-complete to work but as I was unsure it was the correct package during my test, I did not chance it.

Lastly, this worked flawlessly for me, however in my attempt to fix this I added 1386 architecture via sudo dpkg --add-architecture i386 so if you get errors that steam:i386 cannot be found you may need to do this, but I don't think you will. One of the dependencies of steam:i386 is multiarch-support which appears to be preinstalled by default so that should make adding i386 architecture superfluous.


Later Edit to include more info

I was able to later install the latest package directly from Steam and it installed perfectly and the directory folders were installed in .local where they were before. This also added the Steam ppa to the sources so I should get the updates quicker as well(only by a day or so, but..)

I moved the steamapps folder out of the Steam install so that it would not be overwritten, then sudo apt-get remove steam:i386 Then moved the steamapps folder into .local/share/steam answered yes to allow the folders to be overwritten and when started Steam logged me in and the games launched without a hitch.

I'm nearly certain that I had tried the package directly from Steam's website when trying to install before and got the same errors. Installing steam:i386 pulled in the dependencies correctly, and worked fine and I could have left it as was but it bugged me that it seemed "hackey". So you could either install steam:i386 and have it work without fuss, or can remove steam:i386 afterwards and install the package directly from Steam and have the directories were they were previously(and most users expect them to be, this could make it easier to get help form the community in the future).

Either one you choose should give you a working Steam install

  • THANK YOU!!!! Thank you. Thank you. Worked perfectly. I expanded your answer to make it more useful. One question, how did you know to install steam:i386? I didn't come across this as a solution and I spent hours researching it...... – TrailRider Aug 19 '15 at 22:58
0

This answer is left for historical/informational purposes or in case the accepted answer does not work for you. Please try the accepted answer instead!!!

After much stress I finally found several posts that recommended the (mostly) same solution. note that this is a bit hackey but it works, it may cause problems later, or may not I don't know

I found the most reliable answer on an old steam bug report from 2013. Reading the thread it became clear that Steam does not do well with HWE releases and tries to pull the libs from the non HWE repository and this causes the conflict.

There are actually separate issues that I was dealing with but they are related


First was the fact that the "bug" caused the Lib.so file to not be found if you installed Steam without proprietary drivers
If you were use the proprietary driver(as least with Nvidia, not sure about Radeon) they installed their own libs that Steam could find. Without the closed drivers you would get the fatal error that "you are missing the following 32 bit libs Steam may fail to start Lib.so*" Then the Steam crash notification would come up. This caused the confusion above where one time Steam fails and the next time it starts with the

If I understand right the following fix will take care of this issue with the non-propitiatary but I'm not absolutely certain. __

The second issue:

Still related to Steam trying to pull old libs. (or maybe the Ubuntu repo has not updated the newer ones to work yet, that was not clear to me)

When starting with the closed drivers , the window pops up that Steam "needs to install the following..." in the code I posted above. (When using open drivers Steam crashes at the "lib.so" stage)

If you tried to install you got the errors I posted above, but if you just closed the window Steam would launch normally.

NOW THE FIX

The bug report I referenced earlier contained some recent comments that lead me to the answer the relevant comments start here.

The fix is to add i386 architecture then update

sudo dpkg --add-architecture i386
sudo apt-get update

Then install the i386 libs (these are the older libs from the trusty repos as you can see by the commands)

sudo apt-get install libgl1-mesa-dri-lts-trusty:i386 libgl1-mesa-glx-lts-trusty:i386 libc6:i386

As I said above, this may be a hackey way to get the libs needed but every other way I tried either failed outright or left me with the super annoying window popping up wanting to install needed libs every time I started Steam. There is a possibility that these libs may cause issues later but it appears that you can remove all of the files that these commands install by

 sudo apt-get purge  libgl1-mesa-dri-lts-trusty:i386 libgl1-mesa-glx-lts-trusty:i386 libc6:i386

and then remove the last file with

sudo apt-get autoremove

According to my tests, it reverts the system back to before the commands where installed. As most of your system on 14.04.03 is still Trusty and Trusty will be supported for a while yet; I think these libs will be ok but use this fix at your own risk
One thing of note, this fix did not remove a single file, program or lib from my system(you might want to test with the sudo apt-get install -s(the -s switch here means simulation) then check the output on you terminal to make sure it will not on yours).


If any more experienced users out there know of any issues that may arise form installing these libs or knows of a less quick-and-dirty way to fix this, please add info in the comments

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.